uqmi: use -ffunction-sections and --gc-sections, reduces binary size from 57k to 29k
authorFelix Fietkau <nbd@openwrt.org>
Sat, 7 Jun 2014 19:14:17 +0000 (19:14 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 7 Jun 2014 19:14:17 +0000 (19:14 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 41051

package/network/utils/uqmi/Makefile

index 18e0954ad256709ae5651b07ace45a873293a4ef..027fc0d1c2efb4a58cc9c37ae71f6fc8117a8c86 100644 (file)
@@ -34,7 +34,9 @@ define Package/uqmi/description
 endef
 
 TARGET_CFLAGS += \
-       -I$(STAGING_DIR)/usr/include
+       -I$(STAGING_DIR)/usr/include -ffunction-sections -fdata-sections
+
+TARGET_LDFLAGS += -Wl,--gc-sections
 
 CMAKE_OPTIONS += \
        -DDEBUG=1