uboot-omap: Remove omap3_overo configuration
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 28 Nov 2021 21:23:47 +0000 (22:23 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 28 Nov 2021 21:26:27 +0000 (22:26 +0100)
The configs/omap3_overo_defconfig file was removed from upstream U-Boot
in commit ed3294d6d1f9 ("arm: Remove overo board"). Remove it in OpenWrt
too. If someone needs this please add it also to upstream U-Boot.

This fixes the compile of the omap target.

Fixes: ffb807ec90d3 ("omap: update u-boot to 2021.07")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/boot/uboot-omap/Makefile
target/linux/omap/image/Makefile

index 929b6798949218623673af1d2d032490e71e546a..4c12eec29dcbab388f3c536ce399c0141778ab14 100644 (file)
@@ -31,16 +31,12 @@ define U-Boot/am335x_evm
   BUILD_DEVICES:=ti_am335x-evm ti_am335x-bone-black
 endef
 
-define U-Boot/omap3_overo
-  NAME:=Gumstix Overo
-endef
-
 define U-Boot/omap3_beagle
   NAME:=BeagleBoard
   BUILD_DEVICES:=ti_omap3-beagle
 endef
 
-UBOOT_TARGETS:=omap4_panda am335x_evm omap3_overo omap3_beagle
+UBOOT_TARGETS:=omap4_panda am335x_evm omap3_beagle
 
 define Build/InstallDev
        $(foreach device,$(BUILD_DEVICES), \
index 10c6d0ad684ced9588194585f86e1a78162e6c3b..507c91b2cc9aa5f33c73743940e5b8345316ae45 100644 (file)
@@ -38,7 +38,7 @@ define Device/Default
   IMAGE/sdcard.img.gz := omap-sdcard | append-metadata | gzip
 endef
 
-#uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap3_overo uboot-omap-omap4_panda
+#uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap4_panda
 
 define Device/ti_am335x-evm
   DEVICE_VENDOR := Texas Instruments