uml: make use of 'rootfs-part' feature
authorDaniel Golle <daniel@makrotopia.org>
Sat, 22 Jan 2022 00:26:52 +0000 (00:26 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Sun, 23 Jan 2022 19:48:31 +0000 (19:48 +0000)
Use 'rootfs-part' feature instead of referencing the TARGET_uml in
Config-images.in.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
config/Config-images.in
target/linux/uml/Makefile

index 7f118030f23023223ea78f27b8d60b1dea0386a6..dcd7575c3e453547e4c0f1c0840d2b0222982a7b 100644 (file)
@@ -296,7 +296,7 @@ menu "Target Images"
 
        config TARGET_ROOTFS_PARTSIZE
                int "Root filesystem partition size (in MiB)"
-               depends on USES_ROOTFS_PART || TARGET_ROOTFS_EXT4FS || TARGET_uml
+               depends on USES_ROOTFS_PART || TARGET_ROOTFS_EXT4FS
                default 104
                help
                  Select the root filesystem partition size.
index ec662989ecefb5053f726cdcca6d04bba3a86efb..5c884fb9a05e94bce32cc4c4d827574decd41165 100644 (file)
@@ -11,7 +11,7 @@ ifeq ($(HOST_OS),Linux)
 ARCH:=x86_64
 BOARD:=uml
 BOARDNAME:=User Mode Linux
-FEATURES:=squashfs ext4 audio
+FEATURES:=audio ext4 rootfs-part squashfs
 
 KERNEL_PATCHVER:=5.10