gcc: symlink ./lib64 to ./lib for x86_64 as well
authorNicolas Thill <nico@openwrt.org>
Mon, 27 Apr 2009 10:14:30 +0000 (10:14 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 27 Apr 2009 10:14:30 +0000 (10:14 +0000)
SVN-Revision: 15432

toolchain/gcc/Makefile

index 43097880e1ea906f1e41c78466a51fe910ab10ab..9df43af901bad8d4d7b20529bdbf368d36f42f5b 100644 (file)
@@ -193,7 +193,7 @@ define Stage2/Configure
        ln -sf ../include $(TOOLCHAIN_DIR)/usr/$(REAL_GNU_TARGET_NAME)/sys-include
        rm -rf $(TOOLCHAIN_DIR)/usr/$(REAL_GNU_TARGET_NAME)/lib
        ln -sf ../lib $(TOOLCHAIN_DIR)/usr/$(REAL_GNU_TARGET_NAME)/lib
-       $(if $(CONFIG_mips64)$(CONFIG_mips64el),ln -sf ../lib64 $(TOOLCHAIN_DIR)/usr/$(REAL_GNU_TARGET_NAME)/lib64)
+       $(if $(CONFIG_mips64)$(CONFIG_mips64el)$(CONFIG_x86_64),ln -sf ../lib64 $(TOOLCHAIN_DIR)/usr/$(REAL_GNU_TARGET_NAME)/lib64)
        (cd $(HOST_BUILD_DIR2); rm -f config.cache; \
                $(GCC_CONFIGURE_STAGE2) \
        );