image.mk: clean up redundant code related to DEVICE_DTS
authorFelix Fietkau <nbd@nbd.name>
Thu, 14 Jul 2016 11:58:23 +0000 (13:58 +0200)
committerFelix Fietkau <nbd@nbd.name>
Fri, 15 Jul 2016 12:14:11 +0000 (14:14 +0200)
It is used by a core build template, so the variable should be
initialized and added to DEVICE_VARS in the core.
Same for DEVICE_DTS_DIR

Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/image.mk
target/linux/arc770/image/Makefile
target/linux/archs38/image/Makefile
target/linux/bcm53xx/image/Makefile
target/linux/brcm2708/image/Makefile
target/linux/brcm63xx/image/Makefile
target/linux/imx6/image/Makefile
target/linux/ipq806x/image/Makefile
target/linux/kirkwood/image/Makefile
target/linux/lantiq/image/Makefile
target/linux/zynq/image/Makefile

index bf5f0a6a20ff092a036889fc777c6fe4f95fd8f4..b257eae121e42f153e886b8873928989ed04a720 100644 (file)
@@ -329,11 +329,15 @@ define Device/Init
   SUBPAGESIZE :=
   UBINIZE_OPTS := -E 5
 
+  DEVICE_DTS :=
+  DEVICE_DTS_DIR :=
+
   FILESYSTEMS := $(TARGET_FILESYSTEMS)
 endef
 
 DEFAULT_DEVICE_VARS := \
   DEVICE_NAME KERNEL KERNEL_INITRAMFS KERNEL_INITRAMFS_IMAGE \
+  DEVICE_DTS DEVICE_DTS_DIR \
   UBOOTENV_IN_UBI KERNEL_IN_UBI \
   BLOCKSIZE PAGESIZE SUBPAGESIZE \
   UBINIZE_OPTS
index 47c936e556c1683806f0b51f9265932973cc4341..1e44d6abd581fe17e20b2b09f90074cb2be99036 100644 (file)
@@ -24,9 +24,8 @@ define Device/Default
   PROFILES = Default $$(DEVICE_PROFILE)
   KERNEL_DEPENDS = $$(wildcard ../dts/$$(DEVICE_DTS).dts)
   DEVICE_PROFILE :=
-  DEVICE_DTS :=
 endef
-DEVICE_VARS += DEVICE_PROFILE DEVICE_DTS
+DEVICE_VARS += DEVICE_PROFILE
 
 define Device/vmlinux
   KERNEL_SUFFIX := .elf
index 03bd8ee8ebe9b25b0e9c4d324bdf345cf62280fc..42b13e618d654d4b1eabd3f16e0956cb888540fa 100644 (file)
@@ -24,9 +24,8 @@ define Device/Default
   PROFILES = Default $$(DEVICE_PROFILE)
   KERNEL_DEPENDS = $$(wildcard ../dts/$$(DEVICE_DTS).dts)
   DEVICE_PROFILE :=
-  DEVICE_DTS :=
 endef
-DEVICE_VARS += DEVICE_PROFILE DEVICE_DTS
+DEVICE_VARS += DEVICE_PROFILE
 
 define Device/vmlinux
   KERNEL_SUFFIX := .elf
index 0709643b29bc04780291e60b03e586893d1cebc3..89639f4344145e463d07c2367fec73607f26b248 100644 (file)
@@ -68,7 +68,7 @@ define Build/seama-nand
                -i $@.entity
 endef
 
-DEVICE_VARS += DEVICE_DTS PRODUCTID SIGNATURE NETGEAR_BOARD_ID NETGEAR_REGION
+DEVICE_VARS += PRODUCTID SIGNATURE NETGEAR_BOARD_ID NETGEAR_REGION
 
 define Device/Default
   # .dtb files are prefixed by SoC type, e.g. bcm4708- which is not included in device/image names
index 6916a2b4aed43a273142517bd93c178d970d4885..7656211310e3e9fcb36963b63bcfa96866a13f56 100644 (file)
@@ -49,9 +49,7 @@ define Device/Default
   KERNEL := kernel-bin | kernel-img
   IMAGES := sdcard.img
   IMAGE/sdcard.img := boot-img | sdcard-img
-  DEVICE_DTS :=
 endef
-DEVICE_VARS += DEVICE_DTS
 
 define Device/rpi
   DEVICE_TITLE := Raspberry Pi B/B+/CM/Zero
index 2c82c34363a6d706735e59d40bb40ed16c6613bd..5a1918c90b3b6a0f2f372c97e8eab0852bdbeac4 100644 (file)
@@ -165,10 +165,8 @@ define Device/Default
   PROFILES = Default $$(DEVICE_NAME)
   KERNEL_DEPENDS = $$(wildcard ../dts/$$(DEVICE_DTS).dts)
   KERNEL_INITRAMFS_SUFFIX := .elf
-  DEVICE_DTS :=
   DEVICE_DTS_DIR := ../dts
 endef
-DEVICE_VARS += DEVICE_DTS DEVICE_DTS_DIR
 
 ATH5K_PACKAGES := kmod-ath5k wpad-mini
 ATH9K_PACKAGES := kmod-ath9k wpad-mini
index ff70b88170ffd5b2133a32c96c1adb691011021e..9122d9673ae16db166632df058131d99ea3a0d03 100644 (file)
@@ -103,7 +103,6 @@ KERNEL_LOADADDR=0x10008000
 
 define Device/Default
   PROFILES := Generic
-  DEVICE_DTS :=
   FILESYSTEMS := squashfs ext4
   KERNEL_INSTALL := 1
   KERNEL_SUFFIX := -uImage
@@ -114,8 +113,6 @@ define Device/Default
   IMAGES :=
 endef
 
-DEVICE_VARS += DEVICE_DTS
-
 define Device/ventana
   DEVICE_TITLE := Gateworks Ventana family
   DEVICE_DTS:= \
index 0b7c9ef9a0c99d4349ec0cfd43c879c15c13d955..f527fb648f6f65a8cec753153bebe330de17f1c0 100644 (file)
@@ -39,13 +39,12 @@ define Device/Default
        PROFILES := Default
        KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
        KERNEL_INITRAMFS_PREFIX := $$(IMG_PREFIX)-$(1)-initramfs
-       DEVICE_DTS :=
        KERNEL_PREFIX := $$(IMAGE_PREFIX)
        IMAGES :=
        KERNEL_IN_UBI :=
        BOARD_NAME :=
 endef
-DEVICE_VARS += DEVICE_DTS BOARD_NAME KERNEL_SIZE
+DEVICE_VARS += BOARD_NAME KERNEL_SIZE
 
 define Device/LegacyImage
        KERNEL_SUFFIX := -uImage
@@ -165,7 +164,6 @@ define Device/EA8500
        DEVICE_TITLE := Linksys EA8500
        DEVICE_PACKAGES := ath10k-firmware-qca99x0
 endef
-DEVICE_VARS += DEVICE_DTS
 
 define Device/R7500
        $(call Device/DniImage)
index 0c95dd3d6d7b693b364077edc356d844761eb205..2b0c0d9be577bc13453e33fa10eb34bb17f59322 100644 (file)
@@ -10,7 +10,7 @@ NAND_BLOCKSIZE := 2048-128k
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-DEVICE_VARS += DEVICE_DTS KERNEL_SIZE
+DEVICE_VARS += KERNEL_SIZE
 KERNEL_LOADADDR:=0x8000
 TARGET_DEVICES = linksys-audi linksys-viper dockstar goflexnet goflexhome
 
@@ -20,7 +20,6 @@ define Device/Default
   KERNEL_NAME := zImage
   KERNEL_SUFFIX  := -uImage
   KERNEL_INSTALL := 1
-  KERNEL_IN_UBI :=
 endef
 
 define Device/dockstar
index 7cd08c15f6043b09bb9a49f915d663d7cc584e36..95895c223bf1f8a3ddd8fe3a4dccf5ebfef132db 100644 (file)
@@ -213,7 +213,7 @@ define Device/Default
   IMAGES := sysupgrade.bin
   IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
 endef
-DEVICE_VARS += DEVICE_PROFILE DEVICE_DTS DEVICE_DTS_DIR IMAGE_SIZE
+DEVICE_VARS += DEVICE_PROFILE IMAGE_SIZE
 
 define Device/lantiqBrnImage
   KERNEL := kernel-bin | append-dtb | mkbrncmdline | lzma-no-dict
index d803c336b89c8244c3ff159ee16a3da5aa55df35..6f4a909eff6661ad28b0d19f3084f8c1c387c50c 100644 (file)
@@ -54,10 +54,8 @@ KERNEL_ENTRY_POINT=0x8000
 ### Device macros ###
 define Device/Default
        IMG_PREFIX := zynq
-       DEVICE_DTS :=
        PROFILE_SANITIZED :=
 endef
-DEVICE_VARS += DEVICE_DTS
 
 define Device/DefaultConfig
        DEVICE_LC = $(1)