turn util-macros into tools/xorg-macros host build, provides global xorg m4 macros
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 10 Dec 2010 20:23:48 +0000 (20:23 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 10 Dec 2010 20:23:48 +0000 (20:23 +0000)
SVN-Revision: 24452

tools/Makefile
tools/xorg-macros/Makefile [new file with mode: 0644]

index 4a39663cdb0dfebfe4d54d01b01789e7f19b03b1..9a6cf964d9782bca69fed55e0ffe48cbfb7b270c 100644 (file)
@@ -17,6 +17,7 @@ endif
 tools-y += m4 autoconf automake bison pkg-config sed mklibs
 tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
 tools-y += firmware-utils patch-cmdline quilt yaffs2 flock
 tools-y += m4 autoconf automake bison pkg-config sed mklibs
 tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
 tools-y += firmware-utils patch-cmdline quilt yaffs2 flock
+tools-y += xorg-macros
 tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
 tools-$(CONFIG_TARGET_x86) += qemu
 ifneq ($(CONFIG_TARGET_ar71xx),)
 tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
 tools-$(CONFIG_TARGET_x86) += qemu
 ifneq ($(CONFIG_TARGET_ar71xx),)
@@ -46,6 +47,7 @@ $(curdir)/mtd-utils/compile := $(curdir)/e2fsprogs/install
 $(curdir)/mkimage/compile := $(curdir)/sed/install
 $(curdir)/qemu/compile := $(curdir)/e2fsprogs/install
 $(curdir)/upslug2/compile := $(curdir)/automake/install
 $(curdir)/mkimage/compile := $(curdir)/sed/install
 $(curdir)/qemu/compile := $(curdir)/e2fsprogs/install
 $(curdir)/upslug2/compile := $(curdir)/automake/install
+$(curdir)/xorg-macros/compile := $(curdir)/autoconf/install
 
 $(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
 $(curdir)/builddirs-default := $(tools-y)
 
 $(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
 $(curdir)/builddirs-default := $(tools-y)
diff --git a/tools/xorg-macros/Makefile b/tools/xorg-macros/Makefile
new file mode 100644 (file)
index 0000000..b6cb377
--- /dev/null
@@ -0,0 +1,31 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=xorg-macros
+PKG_VERSION:=1.11.0
+
+PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/individual/util/
+PKG_SOURCE:=util-macros-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=22d5cdff672450cb6902e0d68c200dcb
+
+HOST_BUILD_DIR:=$(BUILD_DIR)/util-macros-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Install
+       $(INSTALL_DIR) $(STAGING_DIR_HOST)/share/aclocal
+       $(INSTALL_DATA) $(HOST_BUILD_DIR)/xorg-macros.m4 $(STAGING_DIR_HOST)/share/aclocal/
+endef
+
+define Host/Clean
+       -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+       $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))