targets: fix remaining targets for initramfs builds
authorFlorian Fainelli <florian@openwrt.org>
Fri, 28 Jun 2013 22:56:34 +0000 (22:56 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 28 Jun 2013 22:56:34 +0000 (22:56 +0000)
Fix some bugs that slipped through while making initramfs non exclusive.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 37079

target/linux/adm5120/image/rb1xx.mk
target/linux/malta/image/Makefile
target/linux/orion/Makefile
target/linux/orion/image/generic.mk
target/linux/orion/image/harddisk.mk

index 333adce8059da6c9f18bdc727f30f850ddeaa33b..35529585a448236ac38def20b30a5e657d80f2e4 100644 (file)
@@ -11,8 +11,8 @@ define Image/cmdline/yaffs2
 endef
 
 define Image/BuildKernel/RouterBoard
-       $(CP) $(KDIR)/vmlinux.elf $(call imgname,kernel,rb1xx)
-       $(STAGING_DIR_HOST)/bin/patch-cmdline $(call imgname,kernel,rb1xx) \
+       $(CP) $(KDIR)/vmlinux-initramfs.elf $(call imgname,kernel-initramfs,rb1xx)
+       $(STAGING_DIR_HOST)/bin/patch-cmdline $(call imgname,kernel-initramfs,rb1xx) \
                '$(strip $(call Image/cmdline/yaffs2))'
 endef
 
index c0e520fbeee1e200ba1a258e078a2abac999ff5b..054f7b726509f803b1489aa8da25ca75b4137901 100644 (file)
@@ -27,6 +27,9 @@ endef
 
 define Image/BuildKernel
        cp $(KDIR)/vmlinux.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.elf
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+       cp $(KDIR)/vmlinux-initramfs.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux-initramfs.elf
+endif
        $(call CompressLzma,$(KDIR)/vmlinux,$(KDIR)/vmlinux.bin.lzma)
        $(call MkuImage,lzma,,$(KDIR)/vmlinux.bin.lzma,$(BIN_DIR)/$(IMG_PREFIX)-uImage-lzma)
        $(call CompressGzip,$(KDIR)/vmlinux,$(KDIR)/vmlinux.bin.gz)
index b1d109a1f694bcab2a285badee01a57bb6c5f426..14cb688293dfe35bb8517b1b8c9787a570a4b507 100644 (file)
@@ -17,7 +17,7 @@ LINUX_VERSION:=3.3.8
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="uImage"
+KERNELNAME:="zImage uImage"
 
 DEFAULT_PACKAGES += kmod-ath9k kmod-crypto-mv-cesa wpad-mini kmod-i2c-core kmod-i2c-mv64xxx kmod-rtc-isl1208
 
index 5b7e0b56144480aa18384dd64087816dd71b9077..4e537061927a7a6f6be9520b02d2fa847b49eadd 100644 (file)
@@ -36,6 +36,10 @@ define Image/BuildKernel
  ## Netgear WN802T: mach id 3306 (0x0cea)
 $(call Image/BuildKernel/ARM/zImage,wn802t,"\x0c\x1c\xa0\xe3\xea\x10\x81\xe3")
 $(call Image/BuildKernel/ARM/uImage,wn802t)
+ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
+$(call Image/BuildKernel/ARM/zImage,wn802t,"\x0c\x1c\xa0\xe3\xea\x10\x81\xe3",-initramfs)
+$(call Image/BuildKernel/ARM/uImage,wn802t,-initramfs)
+endif
  ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)  # nothing more to do for a ramdisk build
 $(call Image/BuildKernel/JFFS2uImage,wn802t,$(ERASE_SIZE_64K),uImage)
 $(call Image/Default/FileSizeCheck,$(KDIR)/wn802t-uImage.jffs2,$(shell expr $(KERNEL_MTD_SIZE) \* 1024))
@@ -44,6 +48,10 @@ $(call Image/Default/FileSizeCheck,$(KDIR)/wn802t-uImage.jffs2,$(shell expr $(KE
  ## Netgear WNR854T: mach id 1801 (0x0709)
 $(call Image/BuildKernel/ARM/zImage,wnr854t,"\x07\x1c\xa0\xe3\x09\x10\x81\xe3")
 $(call Image/BuildKernel/ARM/uImage,wnr854t)
+ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
+$(call Image/BuildKernel/ARM/zImage,wnr854t,"\x07\x1c\xa0\xe3\x09\x10\x81\xe3",-initramfs)
+$(call Image/BuildKernel/ARM/uImage,wnr854t,-initramfs)
+endif
  ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)  # nothing more to do for a ramdisk build
 $(call Image/BuildKernel/JFFS2uImage,wnr854t,$(ERASE_SIZE_128K),uImage)
 $(call Image/Default/FileSizeCheck,$(KDIR)/wnr854t-uImage.jffs2,$(shell expr $(KERNEL_MTD_SIZE) \* 1024))
@@ -52,6 +60,10 @@ $(call Image/Default/FileSizeCheck,$(KDIR)/wnr854t-uImage.jffs2,$(shell expr $(K
  ## Linksys WRT350N v2: mach id 1633 (0x0661)
 $(call Image/BuildKernel/ARM/zImage,wrt350nv2,"\x06\x1c\xa0\xe3\x61\x10\x81\xe3")
 $(call Image/BuildKernel/ARM/uImage,wrt350nv2)
+ifeq ($($CONFIG_TARGET_ROOTFS_INITRAMFS),y)
+$(call Image/BuildKernel/ARM/zImage,wrt350nv2,"\x06\x1c\xa0\xe3\x61\x10\x81\xe3",-initramfs)
+$(call Image/BuildKernel/ARM/uImage,wrt350nv2-initramfs)
+endif
  ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)  # nothing more to do for a ramdisk build
 $(call Image/Default/FileSizeCheck,$(KDIR)/wrt350nv2-uImage,$(shell expr $(KERNEL_MTD_SIZE) \* 1024))
  endif
@@ -61,8 +73,8 @@ define Image/BuildKernel/ARM/zImage
  # merge machine id and regular zImage into one file
  # parameters: 1 = machine name, 2 = machine id as string in quotes
        # $(BOARD) kernel zImage for $(1)
-       echo -en $(2) > '$(KDIR)/$(1)-zImage'
-       cat '$(LINUX_DIR)/arch/arm/boot/zImage' >> '$(KDIR)/$(1)-zImage'
+       echo -en $(2) > '$(KDIR)/$(1)-zImage$(3)'
+       cat '$(KDIR)/zImage$(3)' >> '$(KDIR)/$(1)-zImage$(3)'
 endef
 
 define Image/BuildKernel/ARM/uImage
@@ -72,8 +84,8 @@ define Image/BuildKernel/ARM/uImage
        '$(STAGING_DIR_HOST)/bin/mkimage' -A arm -O linux -T kernel \
        -C none -a 0x00008000 -e 0x00008000 -n 'Linux-$(LINUX_VERSION)' \
        -d '$(KDIR)/$(1)-zImage' '$(KDIR)/$(1)-uImage'
- ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)  # only copy uImage for ramdisk build
-       cp '$(KDIR)/$(1)-uImage' '$(BIN_DIR)/openwrt-$(1)-uImage'
+ ifeq ($(2),-initramfs) # only copy uImage for ramdisk build
+       cp '$(KDIR)/$(1)-uImage-initramfs' '$(BIN_DIR)/openwrt-$(1)-uImage-initramfs'
  endif
 endef
 
index c74c6b38acdb11337e5ad15d904329e7a7d7784b..86ee4960daa3905aaed5ab87e8079deee437aee4 100644 (file)
@@ -5,10 +5,6 @@
 # See /LICENSE for more information.
 #
 
-define Image/Prepare
-       cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
-endef
-
 define Image/BuildKernel
        # Orion Kernel uImages
  # DT2: mach id 1514 (0x5EA)