upgrade to latest linaro releases
authorImre Kaloz <kaloz@openwrt.org>
Sat, 14 Jan 2012 22:52:40 +0000 (22:52 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Sat, 14 Jan 2012 22:52:40 +0000 (22:52 +0000)
SVN-Revision: 29748

toolchain/gcc/common.mk
toolchain/gcc/patches/4.5-linaro/600-ubicom_support.patch
toolchain/gcc/patches/4.5-linaro/840-armv4_pass_fix-v4bx_to_ld.patch
toolchain/gcc/patches/4.6-linaro/600-ubicom_support.patch
toolchain/gcc/patches/4.6-linaro/910-mbsd_multi.patch
toolchain/gcc/patches/4.6-linaro/993-arm_insn-opinit-RTX_CODE-fixup.patch [deleted file]
toolchain/gcc/patches/4.6-linaro/999-coldfire.patch

index 8b7453335070b1474cb7dbfedd37c5015efcbf53..7be1ca1c39365c7758e2f0f5aa6fb9bed69b53fe 100644 (file)
@@ -38,16 +38,16 @@ ifdef CONFIG_GCC_VERSION_LLVM
 else
 ifeq ($(findstring linaro, $(CONFIG_GCC_VERSION)),linaro)
     ifeq ($(CONFIG_GCC_VERSION),"4.5-linaro")
-      PKG_REV:=4.5-2011.08
+      PKG_REV:=4.5-2012.01
       PKG_VERSION:=4.5.4
       PKG_VERSION_MAJOR:=4.5
-      PKG_MD5SUM:=c3374e210209e35ad1ea175223d3605c
+      PKG_MD5SUM:=bc353c1e9d96f69bc4348e06a1c4c4fd
     endif
     ifeq ($(CONFIG_GCC_VERSION),"4.6-linaro")
-      PKG_REV:=4.6-2011.08
-      PKG_VERSION:=4.6.2
+      PKG_REV:=4.6-2012.01
+      PKG_VERSION:=4.6.3
       PKG_VERSION_MAJOR:=4.6
-      PKG_MD5SUM:=7417cdb33d7b3a18552b2003a98cadfc
+      PKG_MD5SUM:=67a101dd91c8df3ca58b74c1dacc77b1
     endif
     PKG_SOURCE_URL:=http://launchpad.net/gcc-linaro/$(PKG_VERSION_MAJOR)/$(PKG_REV)/+download/
     PKG_SOURCE:=$(PKG_NAME)-linaro-$(PKG_REV).tar.bz2
index e2dd8c497576b8c0903c6633d34a98cc2e43a38c..dd5c3a732ac465881794d4b00680bdd87dfa4719 100644 (file)
@@ -1,8 +1,8 @@
 --- a/configure
 +++ b/configure
-@@ -3730,6 +3730,9 @@ case "${target}" in
+@@ -3728,6 +3728,9 @@ case "${target}" in
    ip2k-*-*)
-     noconfigdirs="$noconfigdirs target-libiberty target-libstdc++-v3 ${libgcj}"
+     noconfigdirs="$noconfigdirs target-libstdc++-v3 ${libgcj}"
      ;;
 +  ubicom32-*-*)
 +    noconfigdirs="$noconfigdirs target-libffi"
index 8800c03c93d8e6c41e305426f0d09b35d0159527..e2e33c2b391cb4de9fe7e814cf20893f9654f8c5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gcc/config/arm/linux-eabi.h
 +++ b/gcc/config/arm/linux-eabi.h
-@@ -63,12 +63,16 @@
+@@ -63,10 +63,14 @@
  #undef  GLIBC_DYNAMIC_LINKER
  #define GLIBC_DYNAMIC_LINKER "/lib/ld-linux.so.3"
  
@@ -14,7 +14,5 @@
 -#define LINK_SPEC BE8_LINK_SPEC                                               \
 +#define LINK_SPEC BE8_LINK_SPEC TARGET_FIX_V4BX_SPEC                          \
    LINUX_OR_ANDROID_LD (LINUX_TARGET_LINK_SPEC,                                \
-                      LINUX_TARGET_LINK_SPEC " " ANDROID_LINK_SPEC)
+                      LINUX_TARGET_LINK_SPEC " " ANDROID_LINK_SPEC)
  
- #undef  CC1_SPEC
- #define CC1_SPEC                                              \
index 8268b5e922f234adc209a95032f82c165979d68e..79f8c3f39f25f05aad0dca2f188deb6995a7dec7 100644 (file)
@@ -1,8 +1,8 @@
 --- a/configure
 +++ b/configure
-@@ -3608,6 +3608,9 @@ case "${target}" in
+@@ -3602,6 +3602,9 @@ case "${target}" in
    ip2k-*-*)
-     noconfigdirs="$noconfigdirs target-libiberty target-libstdc++-v3 ${libgcj}"
+     noconfigdirs="$noconfigdirs target-libstdc++-v3 ${libgcj}"
      ;;
 +  ubicom32-*-*)
 +    noconfigdirs="$noconfigdirs target-libffi"
 +#define FATAL_EXIT_CODE 33
 --- a/gcc/config.gcc
 +++ b/gcc/config.gcc
-@@ -2662,6 +2662,34 @@ spu-*-elf*)
+@@ -2675,6 +2675,34 @@ spu-*-elf*)
        c_target_objs="${c_target_objs} spu-c.o"
        cxx_target_objs="${cxx_target_objs} spu-c.o"
        ;;
        tm_file="dbxelf.h elfos.h newlib-stdint.h v850/v850.h"
 --- a/libgcc/config.host
 +++ b/libgcc/config.host
-@@ -572,6 +572,15 @@ sparc64-*-netbsd*)
+@@ -563,6 +563,15 @@ sparc64-*-netbsd*)
        ;;
  spu-*-elf*)
        ;;
index 5a1adc971edf617ec8c2e686e2111f8f751f97d5..45a551e6ed956f0993b7f512b8ee5e488d249170 100644 (file)
      { OPT_LEVELS_3_PLUS, OPT_ftree_loop_distribute_patterns, NULL, 1 },
      { OPT_LEVELS_3_PLUS, OPT_fpredictive_commoning, NULL, 1 },
      /* Inlining of functions reducing size is a good idea with -Os
-@@ -1399,6 +1399,17 @@ common_handle_option (struct gcc_options
+@@ -1405,6 +1405,17 @@ common_handle_option (struct gcc_options
                               opts, opts_set, loc, dc);
        break;
  
  -Wfatal-errors  -Wfloat-equal  -Wformat  -Wformat=2 @gol
  -Wno-format-contains-nul -Wno-format-extra-args -Wformat-nonliteral @gol
  -Wformat-security  -Wformat-y2k @gol
-@@ -4495,6 +4495,22 @@ This option is only supported for C and
+@@ -4497,6 +4497,22 @@ This option is only supported for C and
  @option{-Wall} and by @option{-pedantic}, which can be disabled with
  @option{-Wno-pointer-sign}.
  
  @item -Wstack-protector
  @opindex Wstack-protector
  @opindex Wno-stack-protector
-@@ -6317,7 +6333,7 @@ so, the first branch is redirected to ei
+@@ -6319,7 +6335,7 @@ so, the first branch is redirected to ei
  second branch or a point immediately following it, depending on whether
  the condition is known to be true or false.
  
diff --git a/toolchain/gcc/patches/4.6-linaro/993-arm_insn-opinit-RTX_CODE-fixup.patch b/toolchain/gcc/patches/4.6-linaro/993-arm_insn-opinit-RTX_CODE-fixup.patch
deleted file mode 100644 (file)
index 864f972..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/gcc/config/arm/arm-protos.h
-+++ b/gcc/config/arm/arm-protos.h
-@@ -41,11 +41,11 @@ extern unsigned int arm_dbx_register_num
- extern void arm_output_fn_unwind (FILE *, bool);
-   
--#ifdef RTX_CODE
- extern bool arm_vector_mode_supported_p (enum machine_mode);
- extern bool arm_small_register_classes_for_mode_p (enum machine_mode);
- extern int arm_hard_regno_mode_ok (unsigned int, enum machine_mode);
- extern int const_ok_for_arm (HOST_WIDE_INT);
-+#ifdef RTX_CODE
- extern int arm_split_constant (RTX_CODE, enum machine_mode, rtx,
-                              HOST_WIDE_INT, rtx, rtx, int);
- extern RTX_CODE arm_canonicalize_comparison (RTX_CODE, rtx *, rtx *);
index cda4237b432d3fde1b23859bfa3297e32c85ecb7..6083e0bf8242b9d0dc8894ce7de3e6f82cb2616e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gcc/config.gcc
 +++ b/gcc/config.gcc
-@@ -1791,6 +1791,7 @@ m68k-*-linux*)           # Motorola m68k's runnin
+@@ -1804,6 +1804,7 @@ m68k-*-linux*)           # Motorola m68k's runnin
        if test x$sjlj != x1; then
            tmake_file="$tmake_file m68k/t-slibgcc-elf-ver"
        fi