uclibc: make powerpc e500 support independent of the target name, always use it if...
authorFelix Fietkau <nbd@openwrt.org>
Sun, 26 Jun 2011 14:22:55 +0000 (14:22 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 26 Jun 2011 14:22:55 +0000 (14:22 +0000)
SVN-Revision: 27289

toolchain/uClibc/Makefile
toolchain/uClibc/config-0.9.32/powerpc.e500 [new file with mode: 0644]
toolchain/uClibc/config-0.9.32/powerpc.mpc85xx [deleted file]

index 21a180c22551d50ee8e67fd505042234676b9e6d..d74d1ecfc836dfb9ab05714f8d70bcf665f51e05 100644 (file)
@@ -59,7 +59,9 @@ endef
 GEN_CONFIG=$(SCRIPT_DIR)/kconfig.pl -n \
        $(if $(wildcard $(CONFIG_DIR)/common),'+' $(CONFIG_DIR)/common) \
        $(if $(CONFIG_UCLIBC_ENABLE_DEBUG),$(if $(wildcard $(CONFIG_DIR)/debug),'+' $(CONFIG_DIR)/debug)) \
-       $(CONFIG_DIR)/$(ARCH)$(if $(wildcard $(CONFIG_DIR)/$(ARCH).$(BOARD)),.$(BOARD))
+       $(CONFIG_DIR)/$(ARCH)$(strip \
+               $(if $(wildcard $(CONFIG_DIR)/$(ARCH).$(BOARD)),.$(BOARD), \
+                       $(if $(CONFIG_HAS_SPE_FPU),$(if $(wildcard $(CONFIG_DIR)/$(ARCH).e500),.e500))))
 
 define Host/Prepare
        $(call Host/Prepare/Default)
diff --git a/toolchain/uClibc/config-0.9.32/powerpc.e500 b/toolchain/uClibc/config-0.9.32/powerpc.e500
new file mode 100644 (file)
index 0000000..a835c3d
--- /dev/null
@@ -0,0 +1,6 @@
+ARCH_BIG_ENDIAN=y
+# CONFIG_CLASSIC is not set
+CONFIG_E500=y
+TARGET_ARCH="powerpc"
+TARGET_SUBARCH="classic"
+TARGET_powerpc=y
diff --git a/toolchain/uClibc/config-0.9.32/powerpc.mpc85xx b/toolchain/uClibc/config-0.9.32/powerpc.mpc85xx
deleted file mode 100644 (file)
index a835c3d..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-ARCH_BIG_ENDIAN=y
-# CONFIG_CLASSIC is not set
-CONFIG_E500=y
-TARGET_ARCH="powerpc"
-TARGET_SUBARCH="classic"
-TARGET_powerpc=y