sync dropbear with wr, remove zlib dependency
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Mon, 27 Mar 2006 19:20:22 +0000 (19:20 +0000)
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Mon, 27 Mar 2006 19:20:22 +0000 (19:20 +0000)
SVN-Revision: 3508

openwrt/package/Makefile
openwrt/package/dropbear/Makefile
openwrt/package/dropbear/ipkg/dropbear.control
openwrt/package/dropbear/patches/130-scp_argument.patch [deleted file]
openwrt/package/dropbear/patches/130-ssh_ignore_o_and_x_args.patch [new file with mode: 0644]
openwrt/package/dropbear/patches/160-writechannel.patch [deleted file]

index 0f733580b41bebe2d1759f7bb135c58159d812bb..298eaff2f2e6365f5a88ef207f9d268d357b5700 100644 (file)
@@ -308,7 +308,6 @@ curl-compile: openssl-compile zlib-compile
 cyrus-sasl-compile: openssl-compile
 deco-compile: ncurses-compile
 dhcp6-compile: ncurses-compile
-dropbear-compile: zlib-compile
 dsniff-compile: libnids-compile openssl-compile libgdbm-compile
 freetype-compile: zlib-compile
 fprobe-compile: libpcap-compile
index d43e70cfce7f35dc8c8fdbae5bb60a7fa818166d..75eaf6e44c6bb2f39149254d014d5eb0139f7fca 100644 (file)
@@ -3,13 +3,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dropbear
-PKG_VERSION:=0.47
+PKG_VERSION:=0.48.1
 PKG_RELEASE:=1
-PKG_MD5SUM:=cf634614d52278d44dfd9c224a438bf2
+PKG_MD5SUM:=ca8e53a766faec831882831364568421
 
 PKG_SOURCE_URL:=http://matt.ucc.asn.au/dropbear/releases/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_CAT:=bzcat
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
index 800a0ebc31508d18942cfc49188838ebd9252a01..0aa8cc5b82e29928984bc7d47712b7175579a91f 100644 (file)
@@ -1,5 +1,4 @@
 Package: dropbear
 Priority: optional
-Depends: zlib
 Section: net
 Description: a small SSH 2 server/client designed for small memory environments.
diff --git a/openwrt/package/dropbear/patches/130-scp_argument.patch b/openwrt/package/dropbear/patches/130-scp_argument.patch
deleted file mode 100644 (file)
index befba5d..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -urN dropbear-0.45.old/scp.c dropbear-0.45/scp.c
---- dropbear-0.45.old/scp.c    2005-03-07 05:27:02.000000000 +0100
-+++ dropbear-0.45/scp.c        2005-03-25 11:28:22.000000000 +0100
-@@ -249,9 +249,9 @@
-       args.list = NULL;
-       addargs(&args, "ssh");          /* overwritten with ssh_program */
--      addargs(&args, "-x");
--      addargs(&args, "-oForwardAgent no");
--      addargs(&args, "-oClearAllForwardings yes");
-+//    addargs(&args, "-x");
-+//    addargs(&args, "-oForwardAgent no");
-+//    addargs(&args, "-oClearAllForwardings yes");
-       fflag = tflag = 0;
-       while ((ch = getopt(argc, argv, "dfl:prtvBCc:i:P:q1246S:o:F:")) != -1)
diff --git a/openwrt/package/dropbear/patches/130-ssh_ignore_o_and_x_args.patch b/openwrt/package/dropbear/patches/130-ssh_ignore_o_and_x_args.patch
new file mode 100644 (file)
index 0000000..9b79e48
--- /dev/null
@@ -0,0 +1,22 @@
+diff -ruN dropbear-0.48-old/cli-runopts.c dropbear-0.48-new/cli-runopts.c
+--- dropbear-0.48-old/cli-runopts.c    2006-03-09 16:06:03.000000000 +0100
++++ dropbear-0.48-new/cli-runopts.c    2006-03-11 12:28:54.000000000 +0100
+@@ -188,6 +188,10 @@
+                                       debug_trace = 1;
+                                       break;
+ #endif
++                              case 'o':
++                                      next = &dummy;
++                              case 'x':
++                                      break;
+                               case 'F':
+                               case 'e':
+                               case 'c':
+@@ -199,7 +203,6 @@
+ #ifndef ENABLE_CLI_LOCALTCPFWD
+                               case 'L':
+ #endif
+-                              case 'o':
+                               case 'b':
+                                       next = &dummy;
+                               default:
diff --git a/openwrt/package/dropbear/patches/160-writechannel.patch b/openwrt/package/dropbear/patches/160-writechannel.patch
deleted file mode 100644 (file)
index 0e84a99..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN dropbear-0.47.orig/common-channel.c dropbear-0.47/common-channel.c
---- dropbear-0.47.orig/common-channel.c        2005-12-09 06:42:31.000000000 +0100
-+++ dropbear-0.47/common-channel.c     2006-02-05 00:03:37.000000000 +0100
-@@ -377,7 +377,7 @@
-       cbuf_incrread(cbuf, len);
-       channel->recvdonelen += len;
--      if (fd == channel->writefd && len == maxlen && channel->recveof) { 
-+      if (fd == channel->writefd && len == maxlen && channel->recveof && cbuf_getused(channel->writebuf) == 0) {
-               /* Check if we're closing up */
-               closewritefd(channel);
-               TRACE(("leave writechannel: recveof set"))