Revert "6in4: Corrected tunnelbroker tunnel update URL"
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 19 Jan 2016 23:25:38 +0000 (23:25 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 19 Jan 2016 23:25:38 +0000 (23:25 +0000)
The auth change appears to break the endpoint update for most users and with
my local tests the old update url works just fine.

This reverts commit 99c03a88cb6fed0519efdfaac305794653a12542.

SVN-Revision: 48384

package/network/ipv6/6in4/Makefile
package/network/ipv6/6in4/files/6in4.sh

index b51b12d482a3002df14e63866ace1ab276b23448..9eca57af63fd428e1f1a8356f0e8cbf42b6b6360 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6in4
-PKG_VERSION:=23
+PKG_VERSION:=22
 PKG_RELEASE:=1
 PKG_LICENSE:=GPL-2.0
 
index 05471db14b6dc2adc67ed4dee60fef817964b6b9..59747a3783a934595e318191ff167ecdab92eea6 100755 (executable)
@@ -108,7 +108,7 @@ proto_6in4_setup() {
                        fi
                }
 
-               local url="$http://$username:$password@ipv4.tunnelbroker.net/nic/update?hostname=$tunnelid"
+               local url="$http://ipv4.tunnelbroker.net/nic/update?username=$username&password=$password&hostname=$tunnelid"
                local try=0
                local max=3