host-build.mk: define a variable HOST_STATIC_LINKING which is set to "-static" on...
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 12 Aug 2012 12:34:25 +0000 (12:34 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 12 Aug 2012 12:34:25 +0000 (12:34 +0000)
SVN-Revision: 33138

include/host-build.mk

index 6fc29b3a97925ea9342dc35d5ad4566b40bfe9d8..a8bc79ea67de34648d444644e694539b8d95d219 100644 (file)
@@ -65,6 +65,10 @@ HOST_CONFIGURE_ARGS = \
 
 HOST_CONFIGURE_CMD = ./configure
 
+ifneq ($(HOST_OS),Darwin)
+  HOST_STATIC_LINKING = -static
+endif
+
 define Host/Configure/Default
        (cd $(HOST_BUILD_DIR)/$(3); \
                if [ -x configure ]; then \