busybox: Call ntpd hotplug script for every action
authorHans Dedecker <hans.dedecker@technicolor.com>
Wed, 8 Jun 2016 14:39:04 +0000 (16:39 +0200)
committerJo-Philipp Wich <jo@mein.io>
Fri, 10 Jun 2016 16:05:08 +0000 (18:05 +0200)
Daemons that are waiting for a timesync are only triggered when the action is stratum.
As step is the first sync action pass all actions to the ntpd hotplug scripts; it's up
to the ntpd hotplugscript to filter out the actions it is interested in.

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
package/utils/busybox/Makefile
package/utils/busybox/files/ntpd-hotplug

index 50e2baa031845ddd6a1fcb71007487bc998ad28b..36d02e2e912498fb9469536ab4406fba93a03e79 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.24.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index ddc1490a47c7965d2328ad6b94c21013de1d5d49..8d6d6091661998d86e456606e52f2b638fcb70ab 100755 (executable)
@@ -1,3 +1,2 @@
 #!/bin/sh
-[ "$1" = stratum ] || exit 0
 ACTION="$1" /sbin/hotplug-call ntp