ustream-ssl: enable SNI when building for cyassl
authorJohn Crispin <john@openwrt.org>
Wed, 1 Apr 2015 10:42:33 +0000 (10:42 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 1 Apr 2015 10:42:33 +0000 (10:42 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 45216

package/libs/ustream-ssl/Makefile

index 57777a0bbe2cde2ea58ee9bc2b80586bb67017da..abe74ca4d68421aca645f9e7ee3f3f428d123f37 100644 (file)
@@ -53,7 +53,7 @@ endef
 
 ifeq ($(BUILD_VARIANT),cyassl)
   TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/cyassl
-  CMAKE_OPTIONS += -DCYASSL=on
+  CMAKE_OPTIONS += -DCYASSL=on -DHAVE_SNI
 endif
 ifeq ($(BUILD_VARIANT),polarssl)
   CMAKE_OPTIONS += -DPOLARSSL=on