odhcp6c: allow setting a user-provided prefix as well
authorSteven Barth <cyrus@openwrt.org>
Tue, 12 Feb 2013 08:23:54 +0000 (08:23 +0000)
committerSteven Barth <cyrus@openwrt.org>
Tue, 12 Feb 2013 08:23:54 +0000 (08:23 +0000)
SVN-Revision: 35570

package/network/ipv6/odhcp6c/Makefile
package/network/ipv6/odhcp6c/files/dhcpv6.script
package/network/ipv6/odhcp6c/files/dhcpv6.sh

index d88b97dd5680e3642d813254be329337b48d2990..8bf3ebe434f960da3c5bcb1ee99eceed066e16db 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=odhcp6c
-PKG_VERSION:=2013-02-11
+PKG_VERSION:=2013-02-12
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index 1f019353d5011c6dfa99cc019c82b86d73503707..56f8c39ca4fc550f5e3de739439e8d44e0f2f373 100755 (executable)
@@ -28,6 +28,8 @@ setup_interface () {
                proto_add_ipv6_prefix "$prefix"
        done
 
+       [ -n "$USERPREFIX" ] && proto_add_ipv6_prefix "$USERPREFIX"
+
        # Merge addresses
        for entry in $RA_ADDRESSES; do
                local duplicate=0
index 4bd3a67ed909b41e24f9bcada541da3f86fe2fb6..b1837a9c6a94413c374669c51cf1ff45424823a5 100755 (executable)
@@ -10,14 +10,15 @@ proto_dhcpv6_init_config() {
        proto_config_add_string "clientid"
        proto_config_add_string "reqopts"
        proto_config_add_string "noslaaconly"
+       proto_config_add_string "ip6prefix"
 }
 
 proto_dhcpv6_setup() {
        local config="$1"
        local iface="$2"
 
-       local reqaddress reqprefix clientid reqopts noslaaconly
-       json_get_vars reqaddress reqprefix clientid reqopts noslaaconly
+       local reqaddress reqprefix clientid reqopts noslaaconly ip6prefix
+       json_get_vars reqaddress reqprefix clientid reqopts noslaaconly ip6prefix
 
 
        # Configure
@@ -35,6 +36,7 @@ proto_dhcpv6_setup() {
                append opts "-r$opt"
        done
 
+       [ -n "$ip6prefix" ] && proto_export "USERPREFIX=$ip6prefix"
 
        proto_export "INTERFACE=$config"
        proto_run_command "$config" odhcp6c \