package/swconfig: add sanity checks to prevent a segfault
authorGabor Juhos <juhosg@openwrt.org>
Sat, 8 Jan 2011 17:30:33 +0000 (17:30 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sat, 8 Jan 2011 17:30:33 +0000 (17:30 +0000)
SVN-Revision: 24932

package/swconfig/Makefile
package/swconfig/src/swlib.c

index 24ebaee456a0bc4283714dd54df2816dffa3fcec..363b3a01fd82ac3a7b562563bf8460822f597def 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=swconfig
-PKG_RELEASE:=6
+PKG_RELEASE:=7
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/kernel.mk
index 59456a33d9d5717c38f6abae2a647f6bb3281ef5..c2316d06864ce554568dc107873a0b98f3025875 100644 (file)
@@ -368,11 +368,26 @@ int swlib_set_attr_string(struct switch_dev *dev, struct switch_attr *a, int por
                ptr = (char *)str;
                while(ptr && *ptr)
                {
+                       while(*ptr && isspace(*ptr))
+                               ptr++;
+
+                       if (!*ptr)
+                               break;
+
+                       if (!isdigit(*ptr))
+                               return -1;
+
+                       if (val.len >= dev->ports)
+                               return -1;
+
                        ports[val.len].flags = 0;
                        ports[val.len].id = strtoul(ptr, &ptr, 10);
                        while(*ptr && !isspace(*ptr)) {
                                if (*ptr == 't')
                                        ports[val.len].flags |= SWLIB_PORT_FLAG_TAGGED;
+                               else
+                                       return -1;
+
                                ptr++;
                        }
                        if (*ptr)