Rename 'refresh' to 'update' and make the new 'refresh' actually refresh all the...
authorFelix Fietkau <nbd@openwrt.org>
Mon, 4 Jun 2007 11:14:08 +0000 (11:14 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 4 Jun 2007 11:14:08 +0000 (11:14 +0000)
SVN-Revision: 7488

include/quilt.mk
package/Makefile
target/Makefile
target/linux/Makefile

index e8c3b90a681d67647fb8794cfed2f02ed3dc4374..53fb0a262bef05f7bc34fd9c7ad7a02e2aceef52 100644 (file)
@@ -34,6 +34,7 @@ ifneq ($(QUILT),)
   endef
   $(STAMP_CONFIGURED): $(STAMP_PATCHED)
   prepare: $(STAMP_PATCHED)
   endef
   $(STAMP_CONFIGURED): $(STAMP_PATCHED)
   prepare: $(STAMP_PATCHED)
+  quilt-check: $(STAMP_PATCHED)
 else
   define Build/Patch/Default
        @if [ -d ./patches -a "$$$$(ls ./patches | wc -l)" -gt 0 ]; then \
 else
   define Build/Patch/Default
        @if [ -d ./patches -a "$$$$(ls ./patches | wc -l)" -gt 0 ]; then \
@@ -82,7 +83,7 @@ define Quilt/Refresh/Kernel
        $(call Quilt/RefreshDir,./patches,platform/)
 endef
 
        $(call Quilt/RefreshDir,./patches,platform/)
 endef
 
-refresh: $(STAMP_PREPARED)
+quilt-check: $(STAMP_PREPARED) FORCE
        @[ -f "$(PKG_BUILD_DIR)/.quilt_used" ] || { \
                echo "The source directory was not unpacked using quilt. Please rebuild with QUILT=1"; \
                false; \
        @[ -f "$(PKG_BUILD_DIR)/.quilt_used" ] || { \
                echo "The source directory was not unpacked using quilt. Please rebuild with QUILT=1"; \
                false; \
@@ -95,5 +96,14 @@ refresh: $(STAMP_PREPARED)
                echo "The patches are not sorted in the right order. Please fix."; \
                false; \
        }
                echo "The patches are not sorted in the right order. Please fix."; \
                false; \
        }
+
+refresh: quilt-check
+       @cd $(PKG_BUILD_DIR); quilt pop -a -f >/dev/null 2>/dev/null
+       @cd $(PKG_BUILD_DIR); while quilt next 2>/dev/null >/dev/null && quilt push; do \
+               quilt refresh; \
+       done; ! quilt next 2>/dev/null >/dev/null
+       $(if $(KERNEL_BUILD),$(Quilt/Refresh/Kernel),$(Quilt/Refresh/Package))
+       
+update: quilt-check
        $(if $(KERNEL_BUILD),$(Quilt/Refresh/Kernel),$(Quilt/Refresh/Package))
 
        $(if $(KERNEL_BUILD),$(Quilt/Refresh/Kernel),$(Quilt/Refresh/Package))
 
index 0713e8d23ebdb83b2c2387376101a7069920a15f..94241dbc3d860c5d875c22ea47789377cf1f7753 100644 (file)
@@ -26,12 +26,16 @@ ifeq ($(QUIET),1)
 %-compile %-install: FORCE
        $(MAKE) -C $* $(patsubst $*-%,%,$@) || { $(call MESSAGE, "*** $* $(patsubst $*-%,%,$@) failed"); false; }
 
 %-compile %-install: FORCE
        $(MAKE) -C $* $(patsubst $*-%,%,$@) || { $(call MESSAGE, "*** $* $(patsubst $*-%,%,$@) failed"); false; }
 
-%-prepare %-prereq %-download %-clean %-refresh: FORCE
+%-prepare %-prereq %-download %-clean: FORCE
 else
 else
-%-prepare %-prereq %-download %-clean %-compile %-install %-refresh: FORCE
+%-prepare %-prereq %-download %-clean %-compile %-install: FORCE
 endif
        $(MAKE) -C $* $(patsubst $*-%,%,$@)
 
 endif
        $(MAKE) -C $* $(patsubst $*-%,%,$@)
 
+%-refresh %-update:
+       -$(MAKE) -C $* $(patsubst $*-%,%,$@)
+
+
 # .IGNORE: $(COMPILE_PACKAGES) 
 
 $(TMP_DIR)/.packagedeps: $(TMP_DIR)/.packageinfo
 # .IGNORE: $(COMPILE_PACKAGES) 
 
 $(TMP_DIR)/.packagedeps: $(TMP_DIR)/.packageinfo
@@ -42,6 +46,9 @@ clean: $(patsubst %,%-clean,$(package-) $(package-y) $(package-m))
 prereq: $(PREREQ_PACKAGES)
 download: $(DOWNLOAD_PACKAGES)
 compile: $(COMPILE_PACKAGES)
 prereq: $(PREREQ_PACKAGES)
 download: $(DOWNLOAD_PACKAGES)
 compile: $(COMPILE_PACKAGES)
+ifneq ($(QUILT),)
+  refresh: $(patsubst %,%-refresh,$(package-y) $(package-m) $(package-))
+endif
 
 install-targets: $(INSTALL_PACKAGES)
 install:
 
 install-targets: $(INSTALL_PACKAGES)
 install:
index 438d268b5e9ca568d26288cf2ac01c679e334d1e..a3b15b26592c8b4bc041ba11777b2fcceb4b18e2 100644 (file)
@@ -51,5 +51,5 @@ image_install: image_compile
 imagebuilder_install: image_install
        $(MAKE) -C imagebuilder install
 
 imagebuilder_install: image_install
        $(MAKE) -C imagebuilder install
 
-%-prereq %-prepare %-download %-clean %-compile %-install %-refresh: FORCE
+%-prereq %-prepare %-download %-clean %-compile %-install %-refresh %-update: FORCE
        $(MAKE) -C $* $(patsubst $*-%,%,$@)
        $(MAKE) -C $* $(patsubst $*-%,%,$@)
index 275085448f5d8496dc96a01b4a71937c5bcb59f3..e1248691501fe0df3431c2e1096de435e543f00b 100644 (file)
@@ -7,23 +7,6 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
-download:
-       $(MAKE) -C $(BOARD)-$(KERNEL) download
+clean download prepare compile install menuconfig update refresh: FORCE
+       $(MAKE) -C $(BOARD)-$(KERNEL) $@
 
 
-prepare:
-       $(MAKE) -C $(BOARD)-$(KERNEL) prepare
-
-compile:
-       $(MAKE) -C $(BOARD)-$(KERNEL) compile
-
-install:
-       $(MAKE) -C $(BOARD)-$(KERNEL) install
-       
-refresh:
-       $(MAKE) -C $(BOARD)-$(KERNEL) refresh
-
-menuconfig:
-       $(MAKE) -C $(BOARD)-$(KERNEL) menuconfig
-
-clean:
-       $(MAKE) -C $(BOARD)-$(KERNEL) clean