build: suppress error output in feeds.mk
authorFlorian Eckert <fe@dev.tdt.de>
Mon, 28 May 2018 09:26:50 +0000 (11:26 +0200)
committerPetr Štetiar <ynezz@true.cz>
Thu, 21 Mar 2019 23:40:29 +0000 (00:40 +0100)
If no feed.conf or feeds.conf.default is found on image generation with
the imagebuilder we always get the following message "Unable to open
feeds configuration at <dir>/scripts/feeds line 48." on std error.

To get rid off this needless warning on image generation with the
imagebuilder supress the output in feeds.mk.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
include/feeds.mk

index 4d85a475998dbefc024ff0700085ba225452ce65..9637424c5bc249257342cadcb36cdc18113f453e 100644 (file)
@@ -9,7 +9,7 @@
 -include $(TMP_DIR)/.packageauxvars
 
 FEEDS_INSTALLED:=$(notdir $(wildcard $(TOPDIR)/package/feeds/*))
-FEEDS_AVAILABLE:=$(sort $(FEEDS_INSTALLED) $(shell $(SCRIPT_DIR)/feeds list -n))
+FEEDS_AVAILABLE:=$(sort $(FEEDS_INSTALLED) $(shell $(SCRIPT_DIR)/feeds list -n 2>/dev/null))
 
 PACKAGE_SUBDIRS=$(PACKAGE_DIR)
 ifneq ($(CONFIG_PER_FEED_REPO),)