toolchain/nasm: update to version 2.14
authorDaniel Golle <daniel@makrotopia.org>
Fri, 10 May 2019 23:25:12 +0000 (01:25 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Fri, 10 May 2019 23:30:00 +0000 (01:30 +0200)
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
toolchain/nasm/Makefile
toolchain/nasm/patches/100-backport-upstream-GCC8-compatibility-fixes.patch [deleted file]

index 53b7848caf7409d191ec061451063c04ba8c305b..3efcc86203359775c12ddc65641bf834a3dcf583 100644 (file)
@@ -5,12 +5,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nasm
-PKG_VERSION:=2.13.03
+PKG_VERSION:=2.14
 
 PKG_SOURCE_URL:=https://www.nasm.us/pub/nasm/releasebuilds/$(PKG_VERSION)/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 
-PKG_HASH:=812ecfb0dcbc5bd409aaa8f61c7de94c5b8752a7b00c632883d15b2ed6452573
+PKG_HASH:=97c615dbf02ef80e4e2b6c385f7e28368d51efc214daa98e600ca4572500eec0
 
 HOST_BUILD_PARALLEL:=1
 
diff --git a/toolchain/nasm/patches/100-backport-upstream-GCC8-compatibility-fixes.patch b/toolchain/nasm/patches/100-backport-upstream-GCC8-compatibility-fixes.patch
deleted file mode 100644 (file)
index a6c5027..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/include/nasmlib.h
-+++ b/include/nasmlib.h
-@@ -188,11 +188,9 @@ int64_t readnum(char *str, bool *error);
- int64_t readstrnum(char *str, int length, bool *warn);
- /*
-- * seg_init: Initialise the segment-number allocator.
-  * seg_alloc: allocate a hitherto unused segment number.
-  */
--void pure_func seg_init(void);
--int32_t pure_func seg_alloc(void);
-+int32_t seg_alloc(void);
- /*
-  * many output formats will be able to make use of this: a standard