acx-mac80211: update to v2012-09-23-WIP
authorFlorian Fainelli <florian@openwrt.org>
Sat, 13 Oct 2012 17:46:42 +0000 (17:46 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 13 Oct 2012 17:46:42 +0000 (17:46 +0000)
Patch from Daniel Gimpelevich.

SVN-Revision: 33746

package/acx-mac80211/Makefile
package/acx-mac80211/patches/001-make-compatible-with-recent-mac80211.patch
package/acx-mac80211/patches/004-ratelimit_compile_fix.patch [deleted file]

index d933b837ded4c513f58e4433dc38b2fb117753ac..80e52820e5f18114e9168758e9791e13402800bc 100644 (file)
@@ -9,8 +9,8 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=acx-mac80211
-PKG_REV:=v20120607
-PKG_VERSION:=20120607
+PKG_REV:=v2012-09-23-WIP
+PKG_VERSION:=20121004
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index 34ecf6d4ac887bc152665dd1ffd671466953682f..3b1afee412f5cda132e6909b8ca8856ac5ad520c 100644 (file)
@@ -1,22 +1,7 @@
---- a/acx_func.h
-+++ b/acx_func.h
-@@ -335,8 +335,11 @@ void acx_process_rxbuf(acx_device_t *ade
-  */
- #if CONFIG_ACX_MAC80211_VERSION < KERNEL_VERSION(2, 6, 39)
- int acx_op_tx(struct ieee80211_hw *hw, struct sk_buff *skb);
--#else
-+#elif CONFIG_ACX_MAC80211_VERSION < KERNEL_VERSION(3, 7, 0)
- void acx_op_tx(struct ieee80211_hw *hw, struct sk_buff *skb);
-+#else
-+void acx_op_tx(struct ieee80211_hw *hw, struct ieee80211_tx_control *control,
-+             struct sk_buff *skb);
- #endif
+--- a/main.h
++++ b/main.h
+@@ -44,8 +44,11 @@ void acx_process_rxbuf(acx_device_t *ade
  
- void acx_tx_work(struct work_struct *work);
---- a/common.c
-+++ b/common.c
-@@ -232,8 +232,11 @@ static void acx_rx(acx_device_t *adev, r
- /* Tx Path */
  #if CONFIG_ACX_MAC80211_VERSION < KERNEL_VERSION(2, 6, 39)
  int acx_op_tx(struct ieee80211_hw *hw, struct sk_buff *skb);
 -#else
 +             struct sk_buff *skb);
  #endif
  
- //-void acx_tx_work(struct work_struct *work);
-@@ -5183,7 +5186,12 @@ out:
+--- a/main.c
++++ b/main.c
+@@ -1024,7 +1024,12 @@ out:
   * acx_compat, and hiding this #if/else.  OTOH, inclusion doesnt care
   * about old kernels
   */
diff --git a/package/acx-mac80211/patches/004-ratelimit_compile_fix.patch b/package/acx-mac80211/patches/004-ratelimit_compile_fix.patch
deleted file mode 100644 (file)
index 56110ea..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/common.c
-+++ b/common.c
-@@ -34,6 +34,7 @@
- #include <linux/pci.h>
- #include <linux/nl80211.h>
- #include <linux/ieee80211.h>
-+#include <linux/ratelimit.h>
- #include <net/mac80211.h>