igmpproxy: run in foreground for procd
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Wed, 18 Jul 2018 16:51:59 +0000 (17:51 +0100)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Wed, 18 Jul 2018 17:00:42 +0000 (18:00 +0100)
procd needs processes to stay in foreground to remain under its gaze and
control.  Failure to do so means service stop commands fail to actually
stop the process (procd doesn't think it's running 'cos the process has
exited already as part of its forking routing)

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
package/network/services/igmpproxy/Makefile
package/network/services/igmpproxy/files/igmpproxy.init

index b98f3e59472358b64a2edbde24b5de18e8bc5b09..6ac4172c84066d3f4d7fcfab5c1ff062c1789694 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=igmpproxy
 PKG_VERSION:=0.2.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/pali/igmpproxy/releases/download/${PKG_VERSION}/
index 009bb5d429c676881519e2c851340239fee55329..0c30895ad610cc3a4fb570ddb2d42049cc8b9a7c 100644 (file)
@@ -114,7 +114,7 @@ start_service() {
        [ -n "$has_upstream" ] || return
 
        procd_open_instance
-       procd_set_param command $PROG
+       procd_set_param command $PROG '-n'
        [ -n "$logopts" ] && procd_append_param command $logopts
        procd_append_param command $CONFIGFILE
        procd_set_param file $CONFIGFILE