prereq-build: test availability of Perl Thread::Queue module
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 29 Sep 2015 11:37:10 +0000 (11:37 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 29 Sep 2015 11:37:10 +0000 (11:37 +0000)
This is needed for building automake.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 47069

include/prereq-build.mk

index f5fb9e270a0dc08c965abbbb2550c83c0e814801..6f491375c69657eda6d3cf9a32c3e381bbfec6ea 100644 (file)
@@ -76,6 +76,10 @@ $(eval $(call TestHostCommand,libssl, \
        echo 'int main(int argc, char **argv) { SSL_library_init(); return 0; }' | \
                gcc -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl))
 
+$(eval $(call TestHostCommand,perl-thread-queue, \
+       Please install the Perl Thread::Queue module, \
+       perl -MThread::Queue -e 1))
+
 
 $(eval $(call SetupHostCommand,tar,Please install GNU 'tar', \
        gtar --version 2>&1 | grep GNU, \