gdb: do not depend on libthread-db when using musl libc
authorFlorian Fainelli <florian@openwrt.org>
Tue, 26 Feb 2013 16:39:59 +0000 (16:39 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 26 Feb 2013 16:39:59 +0000 (16:39 +0000)
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 35809

package/devel/gdb/Makefile

index da5dd3fabc627171fda07db6a389e42c677ef446..7663188914348dfe86881f6d013608507a4402f3 100644 (file)
@@ -23,7 +23,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/gdb/Default
   SECTION:=devel
   CATEGORY:=Development
-  DEPENDS:=@!(avr32||cris) +libthread-db +PACKAGE_zlib:zlib
+  DEPENDS:=@!(avr32||cris) +!USE_MUSL:libthread-db +PACKAGE_zlib:zlib
   URL:=http://www.gnu.org/software/gdb/
 endef