jsonpath: rename to jsonfilter and rewrite from flex/bison to lemon
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 18 Jun 2014 10:10:30 +0000 (10:10 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 18 Jun 2014 10:10:30 +0000 (10:10 +0000)
This commit renames the jsonpath binary to jsonfilter to avoid clashing with a Python
extension of the same name.

The utility itself has been rewritten to use SQLite3's lemon parser generator instead
of a flex/bison combination which results in a much smaller binary.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 41258

package/utils/jsonfilter/Makefile [new file with mode: 0644]
package/utils/jsonpath/Makefile [deleted file]

diff --git a/package/utils/jsonfilter/Makefile b/package/utils/jsonfilter/Makefile
new file mode 100644 (file)
index 0000000..1ddb22f
--- /dev/null
@@ -0,0 +1,32 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=jsonfilter
+PKG_VERSION:=2014-06-18
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=http://git.openwrt.org/project/jsonpath.git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=c0e1d4495a8afe51cc1900269d6a6fcf0b51a761
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+CMAKE_INSTALL:=1
+
+PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/jsonfilter
+  SECTION:=base
+  CATEGORY:=Base system
+  DEPENDS:=+libubox +libjson-c
+  TITLE:=OpenWrt JSON filter utility
+  URL:=http://git.openwrt.org/?p=project/jsonpath.git
+endef
+
+define Package/jsonfilter/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/jsonpath $(1)/usr/bin/jsonfilter
+endef
+
+$(eval $(call BuildPackage,jsonfilter))
diff --git a/package/utils/jsonpath/Makefile b/package/utils/jsonpath/Makefile
deleted file mode 100644 (file)
index be64fed..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=jsonpath
-PKG_VERSION:=2014-01-08
-PKG_RELEASE=$(PKG_SOURCE_VERSION)
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=http://git.openwrt.org/project/jsonpath.git
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=f1e3aeb2526ea28db34c7bc714277c1dff26e5fc
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
-CMAKE_INSTALL:=1
-
-PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
-
-include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/cmake.mk
-
-define Package/jsonpath
-  SECTION:=base
-  CATEGORY:=Base system
-  DEPENDS:=+libubox +libjson-c
-  TITLE:=OpenWrt JSON query utility
-endef
-
-define Package/jsonpath/install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/jsonpath $(1)/usr/bin/
-endef
-
-$(eval $(call BuildPackage,jsonpath))