include/kernel.mk: fix download path for linux 3.x
authorJonas Gorski <jogo@openwrt.org>
Tue, 9 Aug 2011 12:19:38 +0000 (12:19 +0000)
committerJonas Gorski <jogo@openwrt.org>
Tue, 9 Aug 2011 12:19:38 +0000 (12:19 +0000)
SVN-Revision: 27939

include/kernel.mk

index 020779fd6320b3b66d0a76b65b4a53e30c52f111..4744e09ef66faa139156ea15c1f70d46dda1d43b 100644 (file)
@@ -48,7 +48,11 @@ else
   LINUX_SOURCE:=linux-$(LINUX_VERSION).tar.bz2
   TESTING:=$(if $(findstring -rc,$(LINUX_VERSION)),/testing,)
   ifeq ($(call qstrip,$(CONFIG_EXTERNAL_KERNEL_TREE)),)
-    LINUX_SITE:=@KERNEL/linux/kernel/v$(KERNEL)$(TESTING)
+    ifeq ($(word 1,$(subst ., ,$(KERNEL_BASE))),3)
+      LINUX_SITE:=@KERNEL/linux/kernel/v3.x$(TESTING)
+    else
+      LINUX_SITE:=@KERNEL/linux/kernel/v$(KERNEL)$(TESTING)
+    endif
   endif
 
   ifneq ($(TARGET_BUILD),1)