dnsmasq: update to dnsmasq v2.76
authorKevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>
Thu, 19 May 2016 10:55:15 +0000 (11:55 +0100)
committerJo-Philipp Wich <jo@mein.io>
Tue, 24 May 2016 11:30:58 +0000 (13:30 +0200)
Update to dnsmasq2.76.  Refresh patches.  Add new patch to fix musl
'poll.h' location warning.

Signed-off-by: Kevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>
package/network/services/dnsmasq/Makefile
package/network/services/dnsmasq/patches/100-fix-dhcp-no-address-warning.patch
package/network/services/dnsmasq/patches/210-dnssec-improve-timestamp-heuristic.patch
package/network/services/dnsmasq/patches/230-fix-poll-h-include-warning-on-musl.patch [new file with mode: 0644]

index f0aba1af44ea92468d4f4b028a054cf8251a830d..d0eea97a9c89e86f135616b280bf4f3b84b4b1c1 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
-PKG_VERSION:=2.75
-PKG_RELEASE:=7
+PKG_VERSION:=2.76
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
-PKG_MD5SUM:=887236f1ddde6eb57cdb9d01916c9f72
+PKG_MD5SUM:=00f5ee66b4e4b7f14538bf62ae3c9461
 
 PKG_LICENSE:=GPL-2.0
 PKG_LICENSE_FILES:=COPYING
index f5b5ca04ec6021bdbe09c9b8a289297935bd00f5..5fc62ffab36d2a31ea3d5a0088ff2d3753f1007d 100644 (file)
@@ -1,15 +1,15 @@
 --- a/src/dhcp.c
 +++ b/src/dhcp.c
-@@ -146,7 +146,7 @@ void dhcp_packet(time_t now, int pxe_fd)
-   struct iovec iov;
+@@ -147,7 +147,7 @@ void dhcp_packet(time_t now, int pxe_fd)
    ssize_t sz; 
    int iface_index = 0, unicast_dest = 0, is_inform = 0;
+   int rcvd_iface_index;
 -  struct in_addr iface_addr;
 +  struct in_addr iface_addr, *addrp = NULL;
    struct iface_param parm;
  #ifdef HAVE_LINUX_NETWORK
    struct arpreq arp_req;
-@@ -275,11 +275,9 @@ void dhcp_packet(time_t now, int pxe_fd)
+@@ -277,11 +277,9 @@ void dhcp_packet(time_t now, int pxe_fd)
      {
        ifr.ifr_addr.sa_family = AF_INET;
        if (ioctl(daemon->dhcpfd, SIOCGIFADDR, &ifr) != -1 )
@@ -23,7 +23,7 @@
        }
        
        for (tmp = daemon->dhcp_except; tmp; tmp = tmp->next)
-@@ -298,7 +296,7 @@ void dhcp_packet(time_t now, int pxe_fd)
+@@ -300,7 +298,7 @@ void dhcp_packet(time_t now, int pxe_fd)
        parm.relay_local.s_addr = 0;
        parm.ind = iface_index;
        
@@ -32,7 +32,7 @@
        {
          /* If we failed to match the primary address of the interface, see if we've got a --listen-address
             for a secondary */
-@@ -318,6 +316,12 @@ void dhcp_packet(time_t now, int pxe_fd)
+@@ -320,6 +318,12 @@ void dhcp_packet(time_t now, int pxe_fd)
          complete_context(match.addr, iface_index, NULL, match.netmask, match.broadcast, &parm);
        }    
        
index 81fbf185b109752bfe877d45879eac8001754a09..ca5a8066964b9214841efc7fc0eff0a6e919b8e7 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Steven Barth <steven@midlink.org>
 
 --- a/src/dnssec.c
 +++ b/src/dnssec.c
-@@ -429,17 +429,24 @@ static time_t timestamp_time;
+@@ -462,17 +462,24 @@ static time_t timestamp_time;
  int setup_timestamp(void)
  {
    struct stat statbuf;
@@ -36,7 +36,7 @@ Signed-off-by: Steven Barth <steven@midlink.org>
        {
          /* time already OK, update timestamp, and do key checking from the start. */
          if (utime(daemon->timestamp_file, NULL) == -1)
-@@ -460,7 +467,7 @@ int setup_timestamp(void)
+@@ -493,7 +500,7 @@ int setup_timestamp(void)
  
          close(fd);
          
diff --git a/package/network/services/dnsmasq/patches/230-fix-poll-h-include-warning-on-musl.patch b/package/network/services/dnsmasq/patches/230-fix-poll-h-include-warning-on-musl.patch
new file mode 100644 (file)
index 0000000..19300f7
--- /dev/null
@@ -0,0 +1,18 @@
+dnsmasq: fix warning with poll.h include on musl
+
+Warning is:
+  #warning redirecting incorrect #include <sys/poll.h> to <poll.h>
+
+Signed-off-by: Kevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>
+
+--- a/src/dnsmasq.h
++++ b/src/dnsmasq.h
+@@ -82,7 +82,7 @@ typedef unsigned long long u64;
+ #if defined(HAVE_SOLARIS_NETWORK)
+ #  include <sys/sockio.h>
+ #endif
+-#include <sys/poll.h>
++#include <poll.h>
+ #include <sys/wait.h>
+ #include <sys/time.h>
+ #include <sys/un.h>