kernel: bump 4.19 to 4.19.52
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 18 Jun 2019 11:19:59 +0000 (13:19 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 18 Jun 2019 12:47:53 +0000 (14:47 +0200)
Refreshed all patches.

Fixes:

- CVE-2019-11479
- CVE-2019-11478
- CVE-2019-11477

Also fix a malformed patch issue caught during refresh.

It was caused by removing a whitespace without altering
the index values in a patch which alters a patch.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Fixes: cf6526249298 ("kernel: bump 4.19 to 4.19.51")
Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/ath79/patches-4.19/0027-MIPS-ath79-drop-legacy-IRQ-code.patch
target/linux/ath79/patches-4.19/0028-MIPS-ath79-drop-machfiles.patch
target/linux/ath79/patches-4.19/910-unaligned_access_hacks.patch
target/linux/generic/backport-4.19/370-netfilter-nf_flow_table-fix-offloaded-connection-tim.patch
target/linux/generic/hack-4.19/902-debloat_proc.patch

index 778b599dc47ac9e38b4738e0c2c7871ae9080f8c..a3fe16bf92309238f1f438c4bc9999a1ad86fa2e 100644 (file)
@@ -8,11 +8,11 @@ endif
 
 LINUX_VERSION-4.9 = .182
 LINUX_VERSION-4.14 = .127
-LINUX_VERSION-4.19 = .51
+LINUX_VERSION-4.19 = .52
 
 LINUX_KERNEL_HASH-4.9.182 = b16e12681a0638368479d73a9b1b8e9407c1ae4b7ae52fdf236d9e5657999695
 LINUX_KERNEL_HASH-4.14.127 = d7464c2379cdee46548ae9f848671f4669d4003af4034f3f738f2f0511ec75b3
-LINUX_KERNEL_HASH-4.19.51 = 7afa920d776f8ca3fc3ced5026cc02c5ccc960c58314050982c307589b5a8d70
+LINUX_KERNEL_HASH-4.19.52 = 266ee655620c3689ae94761970d6827fffc919760caf815427ad22730ba4381e
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 79f003d2ea3df63157deda642af56d3bbabd15c5..6586f084314145968c31768451ef2337a6a8d4d6 100644 (file)
@@ -208,7 +208,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
  
  #include <asm/bootinfo.h>
  #include <asm/idle.h>
-@@ -311,6 +312,11 @@ void __init plat_time_init(void)
+@@ -305,6 +306,11 @@ void __init plat_time_init(void)
        mips_hpt_frequency = cpu_clk_rate / 2;
  }
  
index 0515b206b04d7d1df11bcebd209ad151674e49d0..1901e6e4374a825835550577cd9f574bcf8e7a83 100644 (file)
@@ -944,7 +944,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
  
  #define ATH79_SYS_TYPE_LEN    64
  
-@@ -236,25 +235,21 @@ void __init plat_mem_setup(void)
+@@ -230,25 +229,21 @@ void __init plat_mem_setup(void)
        else if (fw_passed_dtb)
                __dt_setup_arch((void *)KSEG0ADDR(fw_passed_dtb));
  
@@ -979,7 +979,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
  {
        struct device_node *np;
        struct clk *clk;
-@@ -284,66 +279,12 @@ static void __init ath79_of_plat_time_in
+@@ -278,66 +273,12 @@ static void __init ath79_of_plat_time_in
        clk_put(clk);
  }
  
index f765a08c985615540e7e955e5a0722e843dc343f..bb7f847e1b150357c5e1a6ca2b5cac7a654e2bcf 100644 (file)
  EXPORT_SYMBOL(xfrm_parse_spi);
 --- a/net/ipv4/tcp_input.c
 +++ b/net/ipv4/tcp_input.c
-@@ -3898,14 +3898,16 @@ static bool tcp_parse_aligned_timestamp(
+@@ -3912,14 +3912,16 @@ static bool tcp_parse_aligned_timestamp(
  {
        const __be32 *ptr = (const __be32 *)(th + 1);
  
index 69f0a5fd2484f5424403bfc89649fdedeb147cb5..07ef724094d8076ef40916af3ec73b8c8259abac 100644 (file)
@@ -82,6 +82,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 @@ -203,6 +221,7 @@ int flow_offload_add(struct nf_flowtable
                return err;
        }
 +      nf_ct_offload_timeout(flow);
        flow->timeout = (u32)jiffies;
        return 0;
index 89d9cf0893b7be77b542140584f667f8e2725258..ef272f171ce66fa40eba474a8cff88a04ccf0d40 100644 (file)
@@ -382,7 +382,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
 --- a/net/ipv4/proc.c
 +++ b/net/ipv4/proc.c
-@@ -523,5 +523,8 @@ static __net_initdata struct pernet_oper
+@@ -524,5 +524,8 @@ static __net_initdata struct pernet_oper
  
  int __init ip_misc_proc_init(void)
  {