bpftools: update to v5.11.16, simplify make
authorTony Ambardar <itugrok@yahoo.com>
Sun, 11 Apr 2021 00:40:21 +0000 (17:40 -0700)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Sat, 24 Apr 2021 11:21:40 +0000 (12:21 +0100)
Update to the latest stable upstream version.

Drop unneeded make variables to remove redundant assignments seen during
invocation of package Makefile.

Also remove the following patch now included upstream:

  * 200-fix-install-param-order-on-macos.patch

Compile and run-tested on malta/mips32be, using bpftool directly and also
libbpf (linked with tc) to inspect and load simple eBPF programs.

Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
package/network/utils/bpftools/Makefile
package/network/utils/bpftools/patches/200-fix-install-param-order-on-macos.patch [deleted file]

index 52963e41484f27c682968c80678ba025ee22b534..f044cc81f850bf2b15e059d1f5eb7651f92364b4 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bpftools
-PKG_VERSION:=5.11.2
-PKG_RELEASE:=2
+PKG_VERSION:=5.11.16
+PKG_RELEASE:=1
 
 PKG_SOURCE:=linux-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/kernel/v5.x
-PKG_HASH:=904a5b3cbaf5264ef8da6c7a5445fa7ea19168ad77fb83a7cc1b8ba95d52d0a0
+PKG_HASH:=21163681d130cbce5a6be39019e2c69e44f284855ddd70b1a3bd039249540f43
 
 PKG_MAINTAINER:=Tony Ambardar <itugrok@yahoo.com>
 
@@ -93,9 +93,11 @@ ifneq ($(BUILD_VARIANT),lib)
   TARGET_LDFLAGS += -Wl,--gc-sections
 endif
 
-MAKE_FLAGS += \
+MAKE_VARS = \
        EXTRA_CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
-       LDFLAGS="$(TARGET_LDFLAGS)" \
+       LDFLAGS="$(TARGET_LDFLAGS)"
+
+MAKE_FLAGS += \
        BPFTOOL_VERSION="$(LINUX_VERSION)" \
        FEATURES_DUMP="$(PKG_BUILD_DIR)/FEATURE-DUMP.openwrt" \
        OUTPUT="$(PKG_BUILD_DIR)/" \
diff --git a/package/network/utils/bpftools/patches/200-fix-install-param-order-on-macos.patch b/package/network/utils/bpftools/patches/200-fix-install-param-order-on-macos.patch
deleted file mode 100644 (file)
index ffb7e2c..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/tools/lib/bpf/Makefile
-+++ b/tools/lib/bpf/Makefile
-@@ -236,7 +236,7 @@ define do_install
-       if [ ! -d '$(DESTDIR_SQ)$2' ]; then             \
-               $(INSTALL) -d -m 755 '$(DESTDIR_SQ)$2'; \
-       fi;                                             \
--      $(INSTALL) $1 $(if $3,-m $3,) '$(DESTDIR_SQ)$2'
-+      $(INSTALL) $(if $3,-m $3,) $1 '$(DESTDIR_SQ)$2'
- endef
- install_lib: all_cmd