include/toplevel: set env GIT_ASKPASS=/bin/true
authorAlexander Couzens <lynxis@fe80.eu>
Wed, 7 Jun 2017 21:56:19 +0000 (23:56 +0200)
committerAlexander Couzens <lynxis@fe80.eu>
Thu, 8 Jun 2017 15:20:55 +0000 (17:20 +0200)
When git-https request a service (e.g. github) which ask for credentials
git will pass this request to the user resulting download.pl to wait for
user input. Set GIT_ASKPASS to stop asking.

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
include/toplevel.mk

index 5fbf5e2ea43f0f7d06bc289986970b382d17cfbd..658eb4ce475e738d43e7f6b8693f7cf408ffa6f4 100644 (file)
@@ -23,6 +23,7 @@ HOSTCC ?= $(CC)
 export REVISION
 export SOURCE_DATE_EPOCH
 export GIT_CONFIG_PARAMETERS='core.autocrlf=false'
 export REVISION
 export SOURCE_DATE_EPOCH
 export GIT_CONFIG_PARAMETERS='core.autocrlf=false'
+export GIT_ASKPASS:=/bin/true
 export MAKE_JOBSERVER=$(filter --jobserver%,$(MAKEFLAGS))
 export GNU_HOST_NAME:=$(shell $(TOPDIR)/scripts/config.guess)
 export HOST_OS:=$(shell uname)
 export MAKE_JOBSERVER=$(filter --jobserver%,$(MAKEFLAGS))
 export GNU_HOST_NAME:=$(shell $(TOPDIR)/scripts/config.guess)
 export HOST_OS:=$(shell uname)