leds: package the NXP PCA963x driver
authorImre Kaloz <kaloz@openwrt.org>
Mon, 23 Feb 2015 11:09:03 +0000 (11:09 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Mon, 23 Feb 2015 11:09:03 +0000 (11:09 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
SVN-Revision: 44510

package/kernel/linux/modules/leds.mk

index 5a5c76a6d91e5161dc142a9e52c6dbf74a536426..3e345e84d4079b6997a8e4f28fbfaad2cd19aa94 100644 (file)
@@ -183,6 +183,22 @@ endef
 $(eval $(call KernelPackage,ledtrig-oneshot))
 
 
+define KernelPackage/leds-pca963x
+  SUBMENU:=$(LEDS_MENU)
+  TITLE:=PCA963x LED support
+  DEPENDS:=+kmod-i2c-core
+  KCONFIG:=CONFIG_LEDS_PCA963X
+  FILES:=$(LINUX_DIR)/drivers/leds/leds-pca963x.ko
+  AUTOLOAD:=$(call AutoLoad,60,leds-pca963x,1)
+endef
+
+define KernelPackage/leds-pca963x/description
+ Driver for the NXP PCA963x I2C LED controllers.
+endef
+
+$(eval $(call KernelPackage,leds-pca963x))
+
+
 define KernelPackage/leds-tlc59116
   SUBMENU:=$(LEDS_MENU)
   TITLE:=TLC59116 LED support