imagebuilder: manifest function show stderr
authorPaul Spooren <mail@aparcar.org>
Sun, 5 Aug 2018 03:17:29 +0000 (12:17 +0900)
committerJohn Crispin <john@phrozen.org>
Mon, 6 Aug 2018 04:54:42 +0000 (06:54 +0200)
This really simplifies debugging, if a package is not found or a feed is
not reachable, a proper stderr is printed. Currently it would only say
`_call_manifest` failed.

Signed-off-by: Paul Spooren <mail@aparcar.org>
target/imagebuilder/files/Makefile

index e0c0132b853c5189fc5bf509123be788e89ef179..76ea19028ed9b2a4b06d96f01bc2d29b69495958 100644 (file)
@@ -119,8 +119,8 @@ _call_image: staging_dir/host/.prereq-build
 _call_manifest: FORCE
        rm -rf $(TARGET_DIR)
        mkdir -p $(TARGET_DIR) $(BIN_DIR) $(TMP_DIR) $(DL_DIR)
-       $(MAKE) package_reload >/dev/null 2>/dev/null
-       $(MAKE) package_install >/dev/null 2>/dev/null
+       $(MAKE) package_reload >/dev/null
+       $(MAKE) package_install >/dev/null
        $(OPKG) list-installed
 
 package_index: FORCE