ar71xx: add support for the UniFi AP Outdoor Plus
authorJohn Crispin <john@openwrt.org>
Thu, 22 Jan 2015 09:35:46 +0000 (09:35 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 22 Jan 2015 09:35:46 +0000 (09:35 +0000)
the GPIO controlling the rf filter is not configured properly by this patch.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
SVN-Revision: 44077

target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/image/Makefile
target/linux/ar71xx/patches-3.14/610-MIPS-ath79-openwrt-machines.patch
target/linux/ar71xx/patches-3.14/616-MIPS-ath79-ubnt-xw.patch

index 7cb3b6f907f052fedfba2a930cb09963d82b7561..444e6fff7fa6cd6229ee3b27fdfe5347ec83cbcb 100755 (executable)
@@ -255,6 +255,9 @@ get_status_led() {
        uap-pro)
                status_led="ubnt:white:dome"
                ;;
+       unifi-outdoor-plus)
+               status_led="ubnt:white:front"
+               ;;
        airgateway)
                status_led="ubnt:white:status"
                ;;
index 63f90b519856ad87b0759e21223b77a3fd1de8df..a870396a0284feeef6f6d1a9c44fdbce91cefee2 100755 (executable)
@@ -738,6 +738,9 @@ ar71xx_board_detect() {
        *"UniFiAP Outdoor")
                name="unifi-outdoor"
                ;;
+       *"UniFiAP Outdoor+")
+               name="unifi-outdoor-plus"
+               ;;
        *WP543)
                name="wp543"
                ;;
index d373699fce628587aaa12613482e4e0a9858e00b..391299f38ae521dda7de69333eaea0e2cb737822 100755 (executable)
@@ -369,6 +369,7 @@ platform_check_image() {
                return 1
                ;;
 
+       unifi-outdoor-plus | \
        uap-pro)
                [ "$magic_long" != "19852003" ] && {
                        echo "Invalid image type."
@@ -484,6 +485,7 @@ platform_do_upgrade() {
        om5p)
                platform_do_upgrade_openmesh "$ARGV"
                ;;
+       unifi-outdoor-plus | \
        uap-pro)
                MTD_CONFIG_ARGS="-s 0x180000"
                default_do_upgrade "$ARGV"
index 68504b7a9b82d6b92f7a90613ba4e119239eedf3..d905bd0b1b741596858fb2b94fe8f482f1b297b3 100644 (file)
@@ -1425,6 +1425,7 @@ $(eval $(call SingleProfile,TPLINK-LZMA,64kraw,SMART-300,smart-300,SMART-300,tty
 $(eval $(call SingleProfile,TPLINK-LZMA,64kraw,OOLITE,oolite,GS-OOLITE,ttyATH0,115200,0x3C000101,1,16Mlzma))
 
 $(eval $(call SingleProfile,UAPPRO,64k,UAPPRO,ubnt-uap-pro,UAP-PRO,ttyS0,115200,BZ,BZ,ar934x))
+$(eval $(call SingleProfile,UAPPRO,64k,UBNTUNIFIOUTDOORPLUS,ubnt-unifi-outdoor-plus,UBNT-UOP,ttyS0,115200,BZ,BZ,ar7240))
 
 $(eval $(call SingleProfile,UBDEV,64kraw,UBDEV01,ubdev01,UBNT-UF,ttyS0,115200,XM,XM,ar7240))
 
@@ -1489,7 +1490,7 @@ $(eval $(call MultiProfile,TLWR941,TLWR941NV2 TLWR941NV3 TLWR941NV4 TLWR941NV6))
 $(eval $(call MultiProfile,TLWR1043,TLWR1043V1 TLWR1043V2))
 $(eval $(call MultiProfile,TLWDR4300,TLWDR3500V1 TLWDR3600V1 TLWDR4300V1 TLWDR4300V1IL TLWDR4310V1 MW4530RV1))
 $(eval $(call MultiProfile,TUBE2H,TUBE2H8M TUBE2H16M))
-$(eval $(call MultiProfile,UBNT,UBNTAIRROUTER UBNTRS UBNTRSPRO UBNTLSSR71 UBNTBULLETM UBNTROCKETM UBNTNANOM UBNTNANOMXW UBNTLOCOXW UBNTUNIFI UBNTUNIFIOUTDOOR UAPPRO UBNTAIRGW))
+$(eval $(call MultiProfile,UBNT,UBNTAIRROUTER UBNTRS UBNTRSPRO UBNTLSSR71 UBNTBULLETM UBNTROCKETM UBNTNANOM UBNTNANOMXW UBNTLOCOXW UBNTUNIFI UBNTUNIFIOUTDOOR UBNTUNIFIOUTDOORPLUS UAPPRO UBNTAIRGW))
 $(eval $(call MultiProfile,WNR612V2,REALWNR612V2 N150R))
 $(eval $(call MultiProfile,WP543,WP543_2M WP543_4M WP543_8M WP543_16M))
 $(eval $(call MultiProfile,WPE72,WPE72_4M WPE72_8M WPE72_16M))
index 4ce926806b0f3152db68fdeaa27482105674bce9..b01c5de1ff58d72e7ed422a314945db56a91dde3 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -16,22 +16,145 @@
+@@ -16,22 +16,146 @@
  
  enum ath79_mach_type {
        ATH79_MACH_GENERIC = 0,
        ATH79_MACH_UBNT_UAP_PRO,        /* Ubiquiti UniFi AP Pro */
        ATH79_MACH_UBNT_UNIFI,          /* Ubiquiti Unifi */
        ATH79_MACH_UBNT_UNIFI_OUTDOOR,  /* Ubiquiti UnifiAP Outdoor */
++      ATH79_MACH_UBNT_UNIFI_OUTDOOR_PLUS, /* Ubiquiti UnifiAP Outdoor+ */
        ATH79_MACH_UBNT_XM,             /* Ubiquiti Networks XM board rev 1.0 */
 +      ATH79_MACH_WHR_G301N,           /* Buffalo WHR-G301N */
 +      ATH79_MACH_WHR_HP_G300N,        /* Buffalo WHR-HP-G300N */
index 3675518f45e31a9797d9bb000b2abd99b6246d1c..8e16697d1b33340ac39013f96fd7e41e1292f880 100644 (file)
@@ -1,6 +1,65 @@
 --- a/arch/mips/ath79/mach-ubnt-xm.c
 +++ b/arch/mips/ath79/mach-ubnt-xm.c
-@@ -332,3 +332,78 @@ static void __init ubnt_uap_pro_setup(vo
+@@ -186,6 +186,19 @@ static struct gpio_led ubnt_unifi_outdoo
+       }
+ };
++static struct gpio_led ubnt_unifi_outdoor_plus_leds_gpio[] __initdata = {
++      {
++              .name           = "ubnt:white:front",
++              .gpio           = 1,
++              .active_low     = 0,
++      }, {
++              .name           = "ubnt:blue:front",
++              .gpio           = 0,
++              .active_low     = 0,
++      }
++};
++
++
+ static void __init ubnt_unifi_setup(void)
+ {
+       u8 *mac = (u8 *) KSEG1ADDR(0x1fff0000);
+@@ -245,6 +258,38 @@ MIPS_MACHINE(ATH79_MACH_UBNT_UNIFI_OUTDO
+            "Ubiquiti UniFiAP Outdoor",
+            ubnt_unifi_outdoor_setup);
++
++static void __init ubnt_unifi_outdoor_plus_setup(void)
++{
++      u8 *mac1 = (u8 *) KSEG1ADDR(0x1fff0000);
++      u8 *mac2 = (u8 *) KSEG1ADDR(0x1fff0000 + ETH_ALEN);
++      u8 *ee = (u8 *) KSEG1ADDR(0x1fff1000);
++
++      ath79_register_m25p80(NULL);
++
++      ath79_register_mdio(0, ~(UBNT_UNIFIOD_PRI_PHYMASK |
++                               UBNT_UNIFIOD_2ND_PHYMASK));
++
++      ath79_init_mac(ath79_eth0_data.mac_addr, mac1, 0);
++      ath79_init_mac(ath79_eth1_data.mac_addr, mac2, 0);
++      ath79_register_eth(0);
++      ath79_register_eth(1);
++
++      ap91_pci_init(ee, NULL);
++
++      ath79_register_leds_gpio(-1, ARRAY_SIZE(ubnt_unifi_outdoor_plus_leds_gpio),
++                               ubnt_unifi_outdoor_plus_leds_gpio);
++
++      ath79_register_gpio_keys_polled(-1, UBNT_XM_KEYS_POLL_INTERVAL,
++                                        ARRAY_SIZE(ubnt_xm_gpio_keys),
++                                        ubnt_xm_gpio_keys);
++}
++
++MIPS_MACHINE(ATH79_MACH_UBNT_UNIFI_OUTDOOR_PLUS, "UBNT-UOP",
++           "Ubiquiti UniFiAP Outdoor+",
++           ubnt_unifi_outdoor_plus_setup);
++
++
+ static struct gpio_led ubnt_uap_pro_gpio_leds[] __initdata = {
+       {
+               .name           = "ubnt:white:dome",
+@@ -332,3 +377,78 @@ static void __init ubnt_uap_pro_setup(vo
  MIPS_MACHINE(ATH79_MACH_UBNT_UAP_PRO, "UAP-PRO", "Ubiquiti UniFi AP Pro",
             ubnt_uap_pro_setup);