kernel: update kernel 4.4 to 4.4.61
authorJo-Philipp Wich <jo@mein.io>
Sat, 15 Apr 2017 15:00:49 +0000 (17:00 +0200)
committerJo-Philipp Wich <jo@mein.io>
Sat, 15 Apr 2017 16:26:41 +0000 (18:26 +0200)
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
include/kernel-version.mk
target/linux/brcm47xx/patches-4.4/159-cpu_fixes.patch
target/linux/lantiq/patches-4.4/0047-irq-fixes.patch
target/linux/lantiq/patches-4.4/0050-MIPS-Lantiq-Fix-cascaded-IRQ-setup.patch [deleted file]
target/linux/ramips/patches-4.4/200-rt3883-fix-pinctrl-typo.patch [deleted file]

index 6f4a1a2955b55503fde3ab19116db3517db1bbe1..0a58a4529a92eb1a852a9b035a67e5e9bc31808e 100644 (file)
@@ -3,11 +3,11 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .43
-LINUX_VERSION-4.4 = .59
+LINUX_VERSION-4.4 = .61
 LINUX_VERSION-4.9 = .20
 
 LINUX_KERNEL_HASH-3.18.43 = 1236e8123a6ce537d5029232560966feed054ae31776fe8481dd7d18cdd5492c
-LINUX_KERNEL_HASH-4.4.59 = 64e9523c4c7fdaf391a16dd19541bb58e39943cb2151aa0c3d15b6aeaba996ca
+LINUX_KERNEL_HASH-4.4.61 = 30dee7164615ad8184eba4ea6f4906b3ceb2fe462a8a4a929c8e9aab8d4a31da
 LINUX_KERNEL_HASH-4.9.20 = 48660806dd32fb8dcbcf5932291bf6cc7d29240070372230871e0f56fea81341
 
 ifdef KERNEL_PATCHVER
index 795969b110620b08ff7fb355e4e520dc33b47074..32a65186db13c205bf993d9df8da9475151ddac7 100644 (file)
        /*
 --- a/arch/mips/mm/tlbex.c
 +++ b/arch/mips/mm/tlbex.c
-@@ -943,6 +943,9 @@ build_get_pgde32(u32 **p, unsigned int t
+@@ -960,6 +960,9 @@ build_get_pgde32(u32 **p, unsigned int t
                uasm_i_srl(p, ptr, ptr, SMP_CPUID_PTRSHIFT);
                uasm_i_addu(p, ptr, tmp, ptr);
  #else
                UASM_i_LA_mostly(p, ptr, pgdc);
  #endif
                uasm_i_mfc0(p, tmp, C0_BADVADDR); /* get faulting address */
-@@ -1284,6 +1287,9 @@ static void build_r4000_tlb_refill_handl
+@@ -1301,6 +1304,9 @@ static void build_r4000_tlb_refill_handl
  #ifdef CONFIG_64BIT
                build_get_pmde64(&p, &l, &r, K0, K1); /* get pmd in K1 */
  #else
                build_get_pgde32(&p, K0, K1); /* get pgd in K1 */
  #endif
  
-@@ -1295,6 +1301,9 @@ static void build_r4000_tlb_refill_handl
+@@ -1312,6 +1318,9 @@ static void build_r4000_tlb_refill_handl
                build_update_entries(&p, K0, K1);
                build_tlb_write_entry(&p, &l, &r, tlb_random);
                uasm_l_leave(&l, p);
                uasm_i_eret(&p); /* return from trap */
        }
  #ifdef CONFIG_MIPS_HUGE_TLB_SUPPORT
-@@ -1871,6 +1880,9 @@ build_r4000_tlbchange_handler_head(u32 *
+@@ -1888,6 +1897,9 @@ build_r4000_tlbchange_handler_head(u32 *
  #ifdef CONFIG_64BIT
        build_get_pmde64(p, l, r, wr.r1, wr.r2); /* get pmd in ptr */
  #else
        build_get_pgde32(p, wr.r1, wr.r2); /* get pgd in ptr */
  #endif
  
-@@ -1917,6 +1929,9 @@ build_r4000_tlbchange_handler_tail(u32 *
+@@ -1934,6 +1946,9 @@ build_r4000_tlbchange_handler_tail(u32 *
        build_tlb_write_entry(p, l, r, tlb_indexed);
        uasm_l_leave(l, *p);
        build_restore_work_registers(p);
index 9efa63d35a2c1c208ba67d57ab3a7e0958a8b88c..f664deb307c96839877495907ed602f3e61bfd0f 100644 (file)
@@ -45,7 +45,7 @@
                        /* disable */
                        ltq_eiu_w32(ltq_eiu_r32(LTQ_EIU_EXIN_INEN) & ~BIT(i),
                                LTQ_EIU_EXIN_INEN);
-@@ -343,10 +343,10 @@ static int icu_map(struct irq_domain *d,
+@@ -344,10 +344,10 @@ static int icu_map(struct irq_domain *d,
                return 0;
  
        for (i = 0; i < exin_avail; i++)
@@ -58,7 +58,7 @@
  
        return 0;
  }
-@@ -441,14 +441,14 @@ int __init icu_of_init(struct device_nod
+@@ -437,14 +437,14 @@ int __init icu_of_init(struct device_nod
        eiu_node = of_find_compatible_node(NULL, NULL, "lantiq,eiu-xway");
        if (eiu_node && !of_address_to_resource(eiu_node, 0, &res)) {
                /* find out how many external irq sources we have */
diff --git a/target/linux/lantiq/patches-4.4/0050-MIPS-Lantiq-Fix-cascaded-IRQ-setup.patch b/target/linux/lantiq/patches-4.4/0050-MIPS-Lantiq-Fix-cascaded-IRQ-setup.patch
deleted file mode 100644 (file)
index c0d7afc..0000000
+++ /dev/null
@@ -1,87 +0,0 @@
-From: Felix Fietkau <nbd@nbd.name>
-Date: Thu, 19 Jan 2017 12:14:44 +0100
-Subject: [PATCH] MIPS: Lantiq: Fix cascaded IRQ setup
-
-With the IRQ stack changes integrated, the XRX200 devices started
-emitting a constant stream of kernel messages like this:
-
-[  565.415310] Spurious IRQ: CAUSE=0x1100c300
-
-This appears to be caused by IP0 firing for some reason without being
-handled. Fix this by setting up IP2-6 as a proper chained IRQ handler and
-calling do_IRQ for all MIPS CPU interrupts.
-
-Cc: john@phrozen.org
-Cc: stable@vger.kernel.org
-Signed-off-by: Felix Fietkau <nbd@nbd.name>
----
-
---- a/arch/mips/lantiq/irq.c
-+++ b/arch/mips/lantiq/irq.c
-@@ -271,6 +271,11 @@ static void ltq_hw5_irqdispatch(void)
- DEFINE_HWx_IRQDISPATCH(5)
- #endif
-+static void ltq_hw_irq_handler(struct irq_desc *desc)
-+{
-+      ltq_hw_irqdispatch(irq_desc_get_irq(desc) - 2);
-+}
-+
- #ifdef CONFIG_MIPS_MT_SMP
- void __init arch_init_ipiirq(int irq, struct irqaction *action)
- {
-@@ -315,23 +320,19 @@ static struct irqaction irq_call = {
- asmlinkage void plat_irq_dispatch(void)
- {
-       unsigned int pending = read_c0_status() & read_c0_cause() & ST0_IM;
--      unsigned int i;
-+      int irq;
--      if ((MIPS_CPU_TIMER_IRQ == 7) && (pending & CAUSEF_IP7)) {
--              do_IRQ(MIPS_CPU_TIMER_IRQ);
--              goto out;
--      } else {
--              for (i = 0; i < MAX_IM; i++) {
--                      if (pending & (CAUSEF_IP2 << i)) {
--                              ltq_hw_irqdispatch(i);
--                              goto out;
--                      }
--              }
-+      if (!pending) {
-+              spurious_interrupt();
-+              return;
-       }
--      pr_alert("Spurious IRQ: CAUSE=0x%08x\n", read_c0_status());
--out:
--      return;
-+      pending >>= CAUSEB_IP;
-+      while (pending) {
-+              irq = fls(pending) - 1;
-+              do_IRQ(MIPS_CPU_IRQ_BASE + irq);
-+              pending &= ~BIT(irq);
-+      }
- }
- static int icu_map(struct irq_domain *d, unsigned int irq, irq_hw_number_t hw)
-@@ -356,11 +357,6 @@ static const struct irq_domain_ops irq_d
-       .map = icu_map,
- };
--static struct irqaction cascade = {
--      .handler = no_action,
--      .name = "cascade",
--};
--
- int __init icu_of_init(struct device_node *node, struct device_node *parent)
- {
-       struct device_node *eiu_node;
-@@ -392,7 +388,7 @@ int __init icu_of_init(struct device_nod
-       mips_cpu_irq_init();
-       for (i = 0; i < MAX_IM; i++)
--              setup_irq(i + 2, &cascade);
-+              irq_set_chained_handler(i + 2, ltq_hw_irq_handler);
-       if (cpu_has_vint) {
-               pr_info("Setting up vectored interrupts\n");
diff --git a/target/linux/ramips/patches-4.4/200-rt3883-fix-pinctrl-typo.patch b/target/linux/ramips/patches-4.4/200-rt3883-fix-pinctrl-typo.patch
deleted file mode 100644 (file)
index aa55fd9..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-From 2583143af8111d430bdca0268b6cdb7ccc7c3f9d Mon Sep 17 00:00:00 2001
-From: Daniel Golle <daniel@makrotopia.org>
-Date: Fri, 13 Jan 2017 05:40:04 +0100
-Subject: [PATCH] mips: ralink/rt3883: fix typo in pinctrl lna_g_func
-
-Signed-off-by: Daniel Golle <daniel@makrotopia.org>
----
- arch/mips/ralink/rt3883.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/arch/mips/ralink/rt3883.c
-+++ b/arch/mips/ralink/rt3883.c
-@@ -36,7 +36,7 @@ static struct rt2880_pmx_func uartlite_f
- static struct rt2880_pmx_func jtag_func[] = { FUNC("jtag", 0, 17, 5) };
- static struct rt2880_pmx_func mdio_func[] = { FUNC("mdio", 0, 22, 2) };
- static struct rt2880_pmx_func lna_a_func[] = { FUNC("lna a", 0, 32, 3) };
--static struct rt2880_pmx_func lna_g_func[] = { FUNC("lna a", 0, 35, 3) };
-+static struct rt2880_pmx_func lna_g_func[] = { FUNC("lna g", 0, 35, 3) };
- static struct rt2880_pmx_func pci_func[] = {
-       FUNC("pci-dev", 0, 40, 32),
-       FUNC("pci-host2", 1, 40, 32),