toolchain/gcc: update linaro-gcc-4.8 to 2014.04
authorFelix Fietkau <nbd@openwrt.org>
Fri, 2 May 2014 21:18:02 +0000 (21:18 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 2 May 2014 21:18:02 +0000 (21:18 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 40664

toolchain/gcc/common.mk
toolchain/gcc/patches/4.8-linaro/010-documentation.patch
toolchain/gcc/patches/4.8-linaro/200-musl.patch
toolchain/gcc/patches/4.8-linaro/800-arm_v5te_no_ldrd_strd.patch
toolchain/gcc/patches/4.8-linaro/870-ppc_no_crtsavres.patch
toolchain/gcc/patches/4.8-linaro/910-mbsd_multi.patch

index 446e9934bc11401700547419543a7141e8f2b258..af971ba78e31e878b4d14515228058210cb4f802 100644 (file)
@@ -34,10 +34,10 @@ ifeq ($(findstring linaro, $(CONFIG_GCC_VERSION)),linaro)
       PKG_COMP:=bz2
     endif
     ifeq ($(CONFIG_GCC_VERSION),"4.8-linaro")
       PKG_COMP:=bz2
     endif
     ifeq ($(CONFIG_GCC_VERSION),"4.8-linaro")
-      PKG_REV:=4.8-2014.01
+      PKG_REV:=4.8-2014.04
       PKG_VERSION:=4.8.3
       PKG_VERSION_MAJOR:=4.8
       PKG_VERSION:=4.8.3
       PKG_VERSION_MAJOR:=4.8
-      PKG_MD5SUM:=b8bc08b05ff079dcdc020336a67ca4e1
+      PKG_MD5SUM:=5ba2f3a449b1658ccc09d27cc7ab3c03
       PKG_COMP:=xz
     endif
     PKG_SOURCE_URL:=http://launchpad.net/gcc-linaro/$(PKG_VERSION_MAJOR)/$(PKG_REV)/+download/
       PKG_COMP:=xz
     endif
     PKG_SOURCE_URL:=http://launchpad.net/gcc-linaro/$(PKG_VERSION_MAJOR)/$(PKG_REV)/+download/
index 3f604ee47069c3d8197d3a770775cc436d56d5bf..5548069d1b154f022f1bc57c4b2471465b65b1c5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gcc/Makefile.in
 +++ b/gcc/Makefile.in
 --- a/gcc/Makefile.in
 +++ b/gcc/Makefile.in
-@@ -4326,18 +4326,10 @@ doc/gcc.info: $(TEXI_GCC_FILES)
+@@ -4327,18 +4327,10 @@ doc/gcc.info: $(TEXI_GCC_FILES)
  doc/gccint.info: $(TEXI_GCCINT_FILES)
  doc/cppinternals.info: $(TEXI_CPPINT_FILES)
  
  doc/gccint.info: $(TEXI_GCCINT_FILES)
  doc/cppinternals.info: $(TEXI_CPPINT_FILES)
  
index dedbb10842898588c8636cbb20aa6893ccb9b77f..bfc35b13ce1f40bed2d835d489811203a681984d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gcc/config.gcc
 +++ b/gcc/config.gcc
 --- a/gcc/config.gcc
 +++ b/gcc/config.gcc
-@@ -551,7 +551,7 @@ case ${target} in
+@@ -559,7 +559,7 @@ case ${target} in
  esac
  
  # Common C libraries.
  esac
  
  # Common C libraries.
@@ -9,7 +9,7 @@
  
  # Common parts for widely ported systems.
  case ${target} in
  
  # Common parts for widely ported systems.
  case ${target} in
-@@ -654,6 +654,9 @@ case ${target} in
+@@ -662,6 +662,9 @@ case ${target} in
      *-*-*uclibc*)
        tm_defines="$tm_defines DEFAULT_LIBC=LIBC_UCLIBC"
        ;;
      *-*-*uclibc*)
        tm_defines="$tm_defines DEFAULT_LIBC=LIBC_UCLIBC"
        ;;
@@ -34,7 +34,7 @@
  #undef  LINK_SPEC
 --- a/gcc/config/i386/linux.h
 +++ b/gcc/config/i386/linux.h
  #undef  LINK_SPEC
 --- a/gcc/config/i386/linux.h
 +++ b/gcc/config/i386/linux.h
-@@ -21,3 +21,4 @@ along with GCC; see the file COPYING3.
+@@ -21,3 +21,4 @@ along with GCC; see the file COPYING3.  
  
  #define GNU_USER_LINK_EMULATION "elf_i386"
  #define GLIBC_DYNAMIC_LINKER "/lib/ld-linux.so.2"
  
  #define GNU_USER_LINK_EMULATION "elf_i386"
  #define GLIBC_DYNAMIC_LINKER "/lib/ld-linux.so.2"
 +Use musl C library
 --- a/gcc/config/mips/linux.h
 +++ b/gcc/config/mips/linux.h
 +Use musl C library
 --- a/gcc/config/mips/linux.h
 +++ b/gcc/config/mips/linux.h
-@@ -18,3 +18,5 @@ along with GCC; see the file COPYING3.
+@@ -18,3 +18,5 @@ along with GCC; see the file COPYING3.  
  <http://www.gnu.org/licenses/>.  */
  
  #define GLIBC_DYNAMIC_LINKER "/lib/ld.so.1"
  <http://www.gnu.org/licenses/>.  */
  
  #define GLIBC_DYNAMIC_LINKER "/lib/ld.so.1"
      ;;
 --- a/gcc/config/mips/linux64.h
 +++ b/gcc/config/mips/linux64.h
      ;;
 --- a/gcc/config/mips/linux64.h
 +++ b/gcc/config/mips/linux64.h
-@@ -27,6 +27,9 @@ along with GCC; see the file COPYING3.
+@@ -27,6 +27,9 @@ along with GCC; see the file COPYING3.  
  #define GLIBC_DYNAMIC_LINKERN32 "/lib32/ld.so.1"
  #define UCLIBC_DYNAMIC_LINKERN32 "/lib32/ld-uClibc.so.0"
  #define BIONIC_DYNAMIC_LINKERN32 "/system/bin/linker32"
  #define GLIBC_DYNAMIC_LINKERN32 "/lib32/ld.so.1"
  #define UCLIBC_DYNAMIC_LINKERN32 "/lib32/ld-uClibc.so.0"
  #define BIONIC_DYNAMIC_LINKERN32 "/system/bin/linker32"
 +                       BIONIC_DYNAMIC_LINKERN32, MUSL_DYNAMIC_LINKERN32)
 --- a/gcc/config/sparc/linux64.h
 +++ b/gcc/config/sparc/linux64.h
 +                       BIONIC_DYNAMIC_LINKERN32, MUSL_DYNAMIC_LINKERN32)
 --- a/gcc/config/sparc/linux64.h
 +++ b/gcc/config/sparc/linux64.h
-@@ -95,6 +95,9 @@ along with GCC; see the file COPYING3.
+@@ -95,6 +95,9 @@ along with GCC; see the file COPYING3.  
  #define GLIBC_DYNAMIC_LINKER32 "/lib/ld-linux.so.2"
  #define GLIBC_DYNAMIC_LINKER64 "/lib64/ld-linux.so.2"
  
  #define GLIBC_DYNAMIC_LINKER32 "/lib/ld-linux.so.2"
  #define GLIBC_DYNAMIC_LINKER64 "/lib64/ld-linux.so.2"
  
index ae4f6516adf8190d77962590e9acb6c7b787d2c4..efa9789c677a1ea108d32baeeb2f3ad2be703d74 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gcc/config/arm/arm.h
 +++ b/gcc/config/arm/arm.h
 --- a/gcc/config/arm/arm.h
 +++ b/gcc/config/arm/arm.h
-@@ -271,7 +271,7 @@ extern void (*arm_lang_output_object_att
+@@ -277,7 +277,7 @@ extern void (*arm_lang_output_object_att
  /* Thumb-1 only.  */
  #define TARGET_THUMB1_ONLY            (TARGET_THUMB1 && !arm_arch_notm)
  
  /* Thumb-1 only.  */
  #define TARGET_THUMB1_ONLY            (TARGET_THUMB1 && !arm_arch_notm)
  
@@ -8,4 +8,4 @@
 +#define TARGET_LDRD                   (arm_arch6 && ARM_DOUBLEWORD_ALIGN \
                                           && !TARGET_THUMB1)
  
 +#define TARGET_LDRD                   (arm_arch6 && ARM_DOUBLEWORD_ALIGN \
                                           && !TARGET_THUMB1)
  
- /* The following two macros concern the ability to execute coprocessor
+ #define TARGET_CRC32                  (arm_arch_crc)
index 7d8f54fcb3bbe37132a00e38a66835bc9b5083ed..4b7fcbd5e1c921600af63701a9ab8b0d098874e4 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gcc/config/rs6000/rs6000.c
 +++ b/gcc/config/rs6000/rs6000.c
 --- a/gcc/config/rs6000/rs6000.c
 +++ b/gcc/config/rs6000/rs6000.c
-@@ -17661,7 +17661,7 @@ rs6000_savres_strategy (rs6000_stack_t *
+@@ -17662,7 +17662,7 @@ rs6000_savres_strategy (rs6000_stack_t *
    /* Define cutoff for using out-of-line functions to save registers.  */
    if (DEFAULT_ABI == ABI_V4 || TARGET_ELF)
      {
    /* Define cutoff for using out-of-line functions to save registers.  */
    if (DEFAULT_ABI == ABI_V4 || TARGET_ELF)
      {
index 645dc43c5bd053f90a522f6d703bb444725a3488..5387f8e86f9ae2575e7505120b205b52b6540872 100644 (file)
      { OPT_LEVELS_2_PLUS, OPT_freorder_blocks, NULL, 1 },
      { OPT_LEVELS_2_PLUS, OPT_freorder_functions, NULL, 1 },
      { OPT_LEVELS_2_PLUS, OPT_ftree_vrp, NULL, 1 },
      { OPT_LEVELS_2_PLUS, OPT_freorder_blocks, NULL, 1 },
      { OPT_LEVELS_2_PLUS, OPT_freorder_functions, NULL, 1 },
      { OPT_LEVELS_2_PLUS, OPT_ftree_vrp, NULL, 1 },
-@@ -488,6 +486,8 @@ static const struct default_options defa
+@@ -489,6 +487,8 @@ static const struct default_options defa
      { OPT_LEVELS_2_PLUS, OPT_fhoist_adjacent_loads, NULL, 1 },
  
      /* -O3 optimizations.  */
      { OPT_LEVELS_2_PLUS, OPT_fhoist_adjacent_loads, NULL, 1 },
  
      /* -O3 optimizations.  */
      { OPT_LEVELS_3_PLUS, OPT_ftree_loop_distribute_patterns, NULL, 1 },
      { OPT_LEVELS_3_PLUS, OPT_fpredictive_commoning, NULL, 1 },
      /* Inlining of functions reducing size is a good idea with -Os
      { OPT_LEVELS_3_PLUS, OPT_ftree_loop_distribute_patterns, NULL, 1 },
      { OPT_LEVELS_3_PLUS, OPT_fpredictive_commoning, NULL, 1 },
      /* Inlining of functions reducing size is a good idea with -Os
-@@ -1423,6 +1423,17 @@ common_handle_option (struct gcc_options
+@@ -1435,6 +1435,17 @@ common_handle_option (struct gcc_options
                               opts, opts_set, loc, dc);
        break;
  
                               opts, opts_set, loc, dc);
        break;
  
  -Wfatal-errors  -Wfloat-equal  -Wformat  -Wformat=2 @gol
  -Wno-format-contains-nul -Wno-format-extra-args -Wformat-nonliteral @gol
  -Wformat-security  -Wformat-y2k @gol
  -Wfatal-errors  -Wfloat-equal  -Wformat  -Wformat=2 @gol
  -Wno-format-contains-nul -Wno-format-extra-args -Wformat-nonliteral @gol
  -Wformat-security  -Wformat-y2k @gol
-@@ -4817,6 +4817,22 @@ This option is only supported for C and
+@@ -4817,6 +4817,22 @@ This option is only supported for C and 
  @option{-Wall} and by @option{-Wpedantic}, which can be disabled with
  @option{-Wno-pointer-sign}.
  
  @option{-Wall} and by @option{-Wpedantic}, which can be disabled with
  @option{-Wno-pointer-sign}.