base-files: don't modify enabled state of service on upgrade
authorJonas Gorski <jonas.gorski@gmail.com>
Mon, 21 Nov 2016 14:16:07 +0000 (15:16 +0100)
committerJonas Gorski <jonas.gorski@gmail.com>
Mon, 21 Nov 2016 17:40:15 +0000 (18:40 +0100)
Properly stop/start services on upgrade, but don't change the enabled
state.

Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
Acked-by: Jo-Philipp Wich <jo@mein.io>
package/base-files/Makefile
package/base-files/files/lib/functions.sh

index 637d88b5adc5bbcf76557448698642e49afe4874..85406a035dc79748b949120dbe640fd104bd4648 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=170
+PKG_RELEASE:=171
 PKG_FLAGS:=nonshared
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
index 232a1c4ed250a71ffe7a78f3864d415a49b94550..a5838f6035cd5462a2fb51043885923ad261a2b3 100755 (executable)
@@ -175,7 +175,9 @@ default_prerm() {
                if [ -n "$root" ]; then
                        ${shell:-/bin/sh} "$root/etc/rc.common" "$root$i" disable
                else
-                       "$i" disable
+                       if [ "$PKG_UPGRADE" != "1" ]; then
+                               "$i" disable
+                       fi
                        "$i" stop
                fi
        done
@@ -240,17 +242,17 @@ default_postinst() {
 
        [ -n "$root" ] || rm -f /tmp/luci-indexcache 2>/dev/null
 
-       if [ "$PKG_UPGRADE" != "1" ]; then
-               local shell="$(which bash)"
-               for i in $(grep -s "^/etc/init.d/" "$root/usr/lib/opkg/info/${pkgname}.list"); do
-                       if [ -n "$root" ]; then
-                               ${shell:-/bin/sh} "$root/etc/rc.common" "$root$i" enable
-                       else
+       local shell="$(which bash)"
+       for i in $(grep -s "^/etc/init.d/" "$root/usr/lib/opkg/info/${pkgname}.list"); do
+               if [ -n "$root" ]; then
+                       ${shell:-/bin/sh} "$root/etc/rc.common" "$root$i" enable
+               else
+                       if [ "$PKG_UPGRADE" != "1" ]; then
                                "$i" enable
-                               "$i" start
                        fi
-               done
-       fi
+                       "$i" start
+               fi
+       done
 
        return $ret
 }