bcm63xx: pad Speedport W303 V images to 4 MiB
authorJonas Gorski <jogo@openwrt.org>
Sun, 27 May 2012 13:22:22 +0000 (13:22 +0000)
committerJonas Gorski <jogo@openwrt.org>
Sun, 27 May 2012 13:22:22 +0000 (13:22 +0000)
Prevents CFE from flashing to the second image offset. Fix up the rootfs
length on first boot else CFE will complain.

SVN-Revision: 31876

target/linux/brcm63xx/image/Makefile

index f82647e98372beef412b27e9c4559b36e0ecb32e..303003c79372cf5ca2f114372aabd68f28a63613 100644 (file)
@@ -93,7 +93,7 @@ define Image/Build/SPW303V
                --output $(BIN_DIR)/openwrt-$(4)-$(1)-cfe.bin.tmp \
                --boardid $(2) --chipid $(3) --entry $(KERNEL_ENTRY) \
                --load-addr $(LOADADDR) --rsa-signature "$(5)" \
-               $(6) $(7) $(8) $(9)
+               --pad 4 $(6) $(7) $(8) $(9)
        # Fix up header
        $(STAGING_DIR_HOST)/bin/spw303v -i $(BIN_DIR)/openwrt-$(4)-$(1)-cfe.bin.tmp \
                -o $(BIN_DIR)/openwrt-$(4)-$(1)-cfe-sysupgrade.bin