ar71xx: fix legacy image build error
authorFelix Fietkau <nbd@nbd.name>
Sat, 7 Jan 2017 20:00:47 +0000 (21:00 +0100)
committerFelix Fietkau <nbd@nbd.name>
Wed, 11 Jan 2017 12:09:21 +0000 (13:09 +0100)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
target/linux/ar71xx/image/legacy.mk

index 32590166b9fa8c8cc2a43804656ba500cbf0de8b..f80b700be8e340cd6feb3d47e89e24d825995c52 100644 (file)
@@ -199,7 +199,7 @@ define Image/BuildLoader
                LZMA_TEXT_START=0x80a00000 LOADADDR=0x80060000 \
                LOADER_DATA="$(KDIR)/vmlinux$(5).bin.lzma" BOARD="$(1)" \
                compile loader.$(2)
-       -$(CP) $(KDIR)/loader-$(1).$(2) $(KDIR)/loader-$(1)$(5).$(2)
+       -$(if $(5),$(CP) $(KDIR)/loader-$(1).$(2) $(KDIR)/loader-$(1)$(5).$(2))
 endef
 
 #