toolchain: fix gcc depends on kernel headers
authorHauke Mehrtens <hauke.mehrtens@intel.com>
Tue, 23 Jul 2019 14:53:51 +0000 (16:53 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 5 Aug 2019 21:22:26 +0000 (23:22 +0200)
GCC needs the kernel headers to compile.
Some GCC file includes asm/unistd.h which is provided by the kernel headers.
Normally the kernel headers build is very fast and ready before the gcc uses
it, but if it clones the kernel from a slow git repository it takes longer
and then it could be that the gcc already wants to use the kernel headers
before they are available. This patch fixes this problem by adding the
missing dependency.

Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com>
toolchain/Makefile

index 0336b2f72cee18fefa66cce218c553b9b99a6e30..23a5529eed3b756382b99d6d2d365735da00ccd1 100644 (file)
@@ -49,7 +49,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
 
   $(curdir)/gcc/initial/compile+=$(curdir)/binutils/compile
   $(curdir)/$(LIBC)/compile:=$(curdir)/gcc/initial/compile
-  $(curdir)/gcc/final/compile:=$(curdir)/$(LIBC)/compile
+  $(curdir)/gcc/final/compile:=$(curdir)/$(LIBC)/compile $(curdir)/kernel-headers/compile
   $(curdir)/$(LIBC)/utils/compile:=$(curdir)/gcc/final/compile
 endif