fstools: fix multiple extroot problems
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 25 Feb 2015 13:03:16 +0000 (13:03 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 25 Feb 2015 13:03:16 +0000 (13:03 +0000)
- Support external overlays on non-MTD systems again
- Account for new directory structure of overlayfs partitions (additional upper/ component)
- Support executing block from either overlay or rom
- Support loading fstab from either overlay or rom
- Log extroot failures to dmesg

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 44535

package/system/fstools/Makefile

index 3ddc0065ff80c43c0f1a33ace865f0edc628ab48..7c9f6200d935b55a4cd05553e267d187de7d5723 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fstools
-PKG_VERSION:=2015-01-28
+PKG_VERSION:=2015-02-25
 
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/fstools.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=6a448a100c7ce8b8b85f262ba1258e54363da9cc
+PKG_SOURCE_VERSION:=4b68e9f9ea894bf58d31e26ca5ed92c81b1a115e
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 CMAKE_INSTALL:=1
 PKG_CHECK_FORMAT_SECURITY:=0