samba36: Don't resolve interfaces.
authorRosen Penev <rosenp@gmail.com>
Thu, 24 Aug 2017 23:51:24 +0000 (16:51 -0700)
committerJohn Crispin <john@phrozen.org>
Wed, 30 Aug 2017 15:05:10 +0000 (17:05 +0200)
It's redundant and also buggy. IPv6 link local addresses and ::1 are not resolved for example. Doesn't matter since lo and br-lan for example, resolve to them.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
Acked-by: Kevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>
package/network/services/samba36/Makefile
package/network/services/samba36/files/samba.init

index 0762dd93071538831e2697a89d46460d7ea701aa..81bad871aa418dd33b9d3b7776c581ad5171adff 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=samba
 PKG_VERSION:=3.6.25
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_SOURCE_URL:=https://download.samba.org/pub/samba \
                https://download.samba.org/pub/samba/stable
index c8413243bac9806399b1763e1bb4cf6bba46c19d..28b0064df9895057976f6895546549dab4fb4bbe 100755 (executable)
@@ -15,12 +15,7 @@ smb_header() {
                for net in $samba_iface; do
                        local device
                        network_is_up $net || continue
-                       network_get_device device "$net" && {
-                               local subnet
-                               network_get_subnet  subnet "$net" && echo -n "$subnet "
-                               network_get_subnet6 subnet "$net" && echo -n "$subnet "
-                       }
-
+                       network_get_device device "$net"
                        echo -n "${device:-$net} "
                done
        )