brcm63xx: Add DT support for HG553
authorJonas Gorski <jogo@openwrt.org>
Thu, 21 Aug 2014 11:28:54 +0000 (11:28 +0000)
committerJonas Gorski <jogo@openwrt.org>
Thu, 21 Aug 2014 11:28:54 +0000 (11:28 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
[jogo: fix linux partition length]
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 42247

41 files changed:
target/linux/brcm63xx/dts/hg553.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/508-board_hw553.patch
target/linux/brcm63xx/patches-3.14/509-board_rta1320_16m.patch
target/linux/brcm63xx/patches-3.14/510-board_spw303v.patch
target/linux/brcm63xx/patches-3.14/511-board_V2500V.patch
target/linux/brcm63xx/patches-3.14/512-board_BTV2110.patch
target/linux/brcm63xx/patches-3.14/514-board_ct536_ct5621.patch
target/linux/brcm63xx/patches-3.14/516-board_96348A-122.patch
target/linux/brcm63xx/patches-3.14/519_board_CPVA502plus.patch
target/linux/brcm63xx/patches-3.14/520-bcm63xx-add-support-for-96368MVWG-board.patch
target/linux/brcm63xx/patches-3.14/521-bcm63xx-add-support-for-96368MVNgr-board.patch
target/linux/brcm63xx/patches-3.14/523-MIPS-BCM63XX-add-963281TAN-reference-board.patch
target/linux/brcm63xx/patches-3.14/524-board_dsl_274xb_rev_f.patch
target/linux/brcm63xx/patches-3.14/525-board_96348w3.patch
target/linux/brcm63xx/patches-3.14/526-board_CT6373-1.patch
target/linux/brcm63xx/patches-3.14/527-board_dva-g3810bn-tl-1.patch
target/linux/brcm63xx/patches-3.14/528-board_nb6.patch
target/linux/brcm63xx/patches-3.14/529-board_fast2604.patch
target/linux/brcm63xx/patches-3.14/530-board_A4001N1.patch
target/linux/brcm63xx/patches-3.14/531-board_AR-5387un.patch
target/linux/brcm63xx/patches-3.14/532-board_AR-5381u.patch
target/linux/brcm63xx/patches-3.14/533-board_rta770bw.patch
target/linux/brcm63xx/patches-3.14/534-board_hw556.patch
target/linux/brcm63xx/patches-3.14/535-board_rta770w.patch
target/linux/brcm63xx/patches-3.14/536-board_fast2704.patch
target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch
target/linux/brcm63xx/patches-3.14/555-board_96318ref.patch
target/linux/brcm63xx/patches-3.14/556-board_96318ref_p300.patch
target/linux/brcm63xx/patches-3.14/557-board_bcm963269bhr.patch
target/linux/brcm63xx/patches-3.14/558-board_AR1004G.patch
target/linux/brcm63xx/patches-3.14/559-board_vw6339gu.patch
target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch
target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch
target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch
target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch
target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
target/linux/brcm63xx/patches-3.14/566-board_A4001N.patch
target/linux/brcm63xx/patches-3.14/567-board_dsl-2751b_e1.patch
target/linux/brcm63xx/profiles/huawei.mk

diff --git a/target/linux/brcm63xx/dts/hg553.dts b/target/linux/brcm63xx/dts/hg553.dts
new file mode 100644 (file)
index 0000000..75fec8b
--- /dev/null
@@ -0,0 +1,30 @@
+/dts-v1/;
+
+/include/ "bcm6358.dtsi"
+
+/ {
+       model = "Huawei EchoLife HG553";
+       compatible = "huawei,hg553", "brcm,bcm6358";
+};
+
+&pflash {
+       status = "ok";
+
+       linux,part-probe = "bcm63xxpart";
+
+       cfe@0 {
+               label = "CFE";
+               reg = <0x000000 0x020000>;
+               read-only;
+       };
+
+       linux@20000 {
+               label = "linux";
+               reg = <0x020000 0xfc0000>;
+       };
+
+       nvram@fe0000 {
+               label = "nvram";
+               reg = <0xfe0000 0x020000>;
+       };
+};
index 5b3e06c0db1919953a913e8578b40fc8c46d6b6d..b56e27d30e4e2bd3448dc91f29e4d34d7e8f48c2 100755 (executable)
@@ -57,15 +57,6 @@ define Image/Build/CFEDTB
                $(7) $(8) $(9) $(10)
 endef
 
-define Image/Build/CFEHW553
-       # Generate the tagged image
-       $(STAGING_DIR_HOST)/bin/imagetag -i $(KDIR)/vmlinux.lzma.cfe -f $(KDIR)/root.$(1) \
-               --output $(BIN_DIR)/openwrt-$(5)-$(1)-cfe.bin \
-               --boardid $(2) --chipid $(3) --entry $(LOADADDR) \
-               --load-addr $(LOADADDR) --tag-version 7 \
-               --block-size 0x20000 --image-offset $(4)
-endef
-
 define Image/Build/CFEAGPF
        # Generate the tagged image
        $(STAGING_DIR_HOST)/bin/imagetag -i $(KDIR)/vmlinux.lzma.cfe -f $(KDIR)/root.$(1) \
@@ -316,9 +307,6 @@ define Image/Build
        # Telsey CPVA642-type (e.g. CPA-ZNTE60T)
        $(call Image/Build/CFE,$(1),CPVA642,6358,CPA-ZNTE60T,,--signature "Telsey Tlc",--signature2 "99.99.999",--second-image-flag "0")
 
-       #HW553
-       $(call Image/Build/CFEHW553,$(1),HW553,6358,0x20000,HW553)
-
        # T-Com Speedport W 303V Typ B
        $(call Image/Build/SPW303V,$(1),96358-502V,6358,SPW303V)
 
@@ -368,6 +356,8 @@ $(eval $(call CfeImageDTB,DSL274XB_C,dsl-274xb-c,AW4139,6358,DSL274XB-C3))
 $(eval $(call CfeImageDTB,DVAG3810BN,dva-g3810bn_tl,96358VW,6358,DVAG3810BN))
 # Huawei HG520v
 $(eval $(call CfeImageDTB,HG520v,hg520v,HW6358GW_B,6358,HG520v,EchoLife_HG520v))
+# Huawei HG553
+$(eval $(call CfeImageDTB,HG553,hg553,HW553,6358,HG553,EchoLife_HG553,--image-offset 0x20000 --block-size 0x20000 --tag-version 7))
 # Huawei HG556a
 $(eval $(call CfeImageDTB,HG556a_AB,hg556a-a,HW556,6358,HG556a_A,EchoLife_HG556a,--image-offset 0x20000 --block-size 0x10000 --tag-version 8))
 $(eval $(call CfeImageDTB,HG556a_AB,hg556a-b,HW556,6358,HG556a_B,EchoLife_HG556a,--image-offset 0x20000 --block-size 0x20000 --tag-version 8))
index 3b26401d8a5624e3c7b40b54e223b309c0e44f23..6d281ae9248120f4d54a4ac6d20c73812a87d137 100644 (file)
@@ -1,12 +1,13 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1471,6 +1471,83 @@ static struct board_info __initdata boar
+@@ -1471,6 +1471,84 @@ static struct board_info __initdata boar
        .spis = nb4_spi_devices,
        .num_spis = ARRAY_SIZE(nb4_spi_devices),
  };
 +
 +static struct board_info __initdata board_HW553 = {
 +      .name                           = "HW553",
++      .of_board_id                                    = "huawei,hg553",
 +      .expected_cpu_id                = 0x6358,
 +
 +      .has_uart0                      = 1,
@@ -84,7 +85,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6358 */
  
  /*
-@@ -1516,6 +1593,7 @@ static const struct board_info __initcon
+@@ -1516,6 +1594,7 @@ static const struct board_info __initcon
        &board_dsl_274xb_rev_c,
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
index 9ce1d25db04623a90ce65d4774a5a701088b6eaa..8349104c16b3b603ae7fb4c58d2919504bfcbe01 100644 (file)
@@ -46,7 +46,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6338 */
  
  /*
-@@ -1564,6 +1603,7 @@ static const struct board_info __initcon
+@@ -1565,6 +1604,7 @@ static const struct board_info __initcon
        &board_96338gw,
        &board_96338w,
        &board_96338w2_e7t,
index 6a8d9c1ec9911d7d54c6d77daed14ce1f7c6d915..8a5c74730fe4061ee33ae0864356624dc6d0104c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1587,6 +1587,72 @@ static struct board_info __initdata boar
+@@ -1588,6 +1588,72 @@ static struct board_info __initdata boar
                .pci_dev                        = 1,
        },
  };
@@ -73,7 +73,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6358 */
  
  /*
-@@ -1634,6 +1700,7 @@ static const struct board_info __initcon
+@@ -1635,6 +1701,7 @@ static const struct board_info __initcon
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
        &board_HW553,
index 847e816976e5bde6c2621a395258598be80ed18d..e96a1a02396ae7cfda436f8cd9cce4df189bdedb 100644 (file)
@@ -66,7 +66,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6348 */
  
  /*
-@@ -1688,6 +1747,7 @@ static const struct board_info __initcon
+@@ -1689,6 +1748,7 @@ static const struct board_info __initcon
        &board_96348_D4PW,
        &board_spw500v,
        &board_96348sv,
@@ -74,7 +74,7 @@
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
-@@ -1726,6 +1786,22 @@ void __init board_bcm963xx_init(void)
+@@ -1727,6 +1787,22 @@ void __init board_bcm963xx_init(void)
                val &= MPI_CSBASE_BASE_MASK;
        }
        boot_addr = (u8 *)KSEG1ADDR(val);
index 20655f96596c447051daf4a9ca13fb0c53254468..b9af2dad7916039e6efa7d936331a3eeddcc7e4b 100644 (file)
@@ -65,7 +65,7 @@
  static struct board_info __initdata board_96348gw = {
        .name                           = "96348GW",
        .of_board_id                    = "brcm,bcm96348gw",
-@@ -1748,6 +1806,7 @@ static const struct board_info __initcon
+@@ -1749,6 +1807,7 @@ static const struct board_info __initcon
        &board_spw500v,
        &board_96348sv,
        &board_V2500V_BB,
index b6e5702627e0446a82b256acadd10be6c16302f7..06f2a704f9fb3ba250569e7ae0e8a39352e84f9b 100644 (file)
@@ -60,7 +60,7 @@
  static struct board_info __initdata board_96348gw = {
        .name                           = "96348GW",
        .of_board_id                    = "brcm,bcm96348gw",
-@@ -1807,6 +1860,7 @@ static const struct board_info __initcon
+@@ -1808,6 +1861,7 @@ static const struct board_info __initcon
        &board_96348sv,
        &board_V2500V_BB,
        &board_V2110,
index cc2690740fde46ad7efcdf7e923fa8510f7abc82..21c2a032a0b86709867be0ced263a5d40a95d214 100644 (file)
@@ -78,7 +78,7 @@
  static struct board_info __initdata board_96348gw = {
        .name                           = "96348GW",
        .of_board_id                    = "brcm,bcm96348gw",
-@@ -1864,6 +1935,7 @@ static const struct board_info __initcon
+@@ -1865,6 +1936,7 @@ static const struct board_info __initcon
        &board_V2500V_BB,
        &board_V2110,
        &board_ct536_ct5621,
index 55d1b986c6be92453b3c4aef3bd8dcc8a97c42e9..fb5bc60a4f2f0605637c096294f6458c56ff0fca 100644 (file)
@@ -41,7 +41,7 @@
  
  static struct board_info __initdata board_ct536_ct5621 = {
        .name                           = "CT536_CT5621",
-@@ -1937,6 +1971,7 @@ static const struct board_info __initcon
+@@ -1938,6 +1972,7 @@ static const struct board_info __initcon
        &board_V2110,
        &board_ct536_ct5621,
        &board_96348A_122,
index 59075d41eaff29e66f3061a5c3f05a2213aede9f..c320f77c7b65c8ce164c2c02d3f522faa2f643de 100644 (file)
@@ -10,7 +10,7 @@ Subject: [PATCH 32/63] bcm63xx: add support for 96368MVWG board.
 
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1935,6 +1935,85 @@ static struct board_info __initdata boar
+@@ -1936,6 +1936,85 @@ static struct board_info __initdata boar
  #endif /* CONFIG_BCM63XX_CPU_6358 */
  
  /*
@@ -96,7 +96,7 @@ Subject: [PATCH 32/63] bcm63xx: add support for 96368MVWG board.
   * all boards
   */
  static const struct board_info __initconst *bcm963xx_boards[] = {
-@@ -1986,6 +2065,10 @@ static const struct board_info __initcon
+@@ -1987,6 +2066,10 @@ static const struct board_info __initcon
        &board_HW553,
        &board_spw303v,
  #endif
index 67df6d61a149d485f7c9b903d96ccbe02aafaa15..fadf2ebf3114c5b53dd01407eb8095c928e60da4 100644 (file)
@@ -9,7 +9,7 @@ Subject: [PATCH 33/63] bcm63xx: add support for 96368MVNgr board.
 
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -2011,6 +2011,72 @@ static struct board_info __initdata boar
+@@ -2012,6 +2012,72 @@ static struct board_info __initdata boar
        .has_ohci0 = 1,
        .has_ehci0 = 1,
  };
@@ -82,7 +82,7 @@ Subject: [PATCH 33/63] bcm63xx: add support for 96368MVNgr board.
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
-@@ -2068,6 +2134,7 @@ static const struct board_info __initcon
+@@ -2069,6 +2135,7 @@ static const struct board_info __initcon
  
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
index 074e526a302dccbd7d3007376b34f8cfde38537c..665c71e3db0122ff0cae3c06f373563085dd1acb 100644 (file)
@@ -86,7 +86,7 @@ Subject: [PATCH] MIPS: BCM63XX: add 963281TAN reference board
  #endif /* CONFIG_BCM63XX_CPU_6328 */
  
  /*
-@@ -2120,6 +2190,7 @@ static const struct board_info __initcon
+@@ -2121,6 +2191,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
index b27c234a72fd09ea90f633f5cea9b34a23a99a74..7b3fba3520987c32cfbd7c5cd42c45f30986cc50 100644 (file)
@@ -122,7 +122,7 @@ Subject: [PATCH 70/79] MIPS: BCM63XX: Add board definition for D-Link
  #endif /* CONFIG_BCM63XX_CPU_6328 */
  
  /*
-@@ -2191,6 +2296,7 @@ static const struct board_info __initcon
+@@ -2192,6 +2297,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
        &board_963281TAN,
index d0059a6797fdca708fa6aef55d585d9e0e79ee6e..72542c695d76c777e4f985f7601a4b5ac4ecb360 100644 (file)
@@ -60,7 +60,7 @@
  static struct board_info __initdata board_96348_D4PW = {
        .name                           = "D-4P-W",
        .expected_cpu_id                = 0x6348,
-@@ -2326,6 +2379,7 @@ static const struct board_info __initcon
+@@ -2327,6 +2380,7 @@ static const struct board_info __initcon
        &board_ct536_ct5621,
        &board_96348A_122,
        &board_CPVA502plus,
index af1ded38fdc6fa5f5fa01efeabe41b01327474d6..34a135dbf4c1cbf6ba55beab09718ca837f0e455 100644 (file)
 +
  static struct board_info __initdata board_HW553 = {
        .name                           = "HW553",
-       .expected_cpu_id                = 0x6358,
-@@ -2391,6 +2516,7 @@ static const struct board_info __initcon
+       .of_board_id                                    = "huawei,hg553",
+@@ -2392,6 +2517,7 @@ static const struct board_info __initcon
        &board_dsl_274xb_rev_c,
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
index bac62473b69d8a0877e31e70b90fa8dd5ff92522..a245ca14d5bc56e5fe9f829671508cba1a67eb6d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -2317,6 +2317,74 @@ static struct board_info __initdata boar
+@@ -2318,6 +2318,74 @@ static struct board_info __initdata boar
                },
        }
  };
@@ -75,7 +75,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6358 */
  
  /*
-@@ -2519,6 +2587,7 @@ static const struct board_info __initcon
+@@ -2520,6 +2588,7 @@ static const struct board_info __initcon
        &board_ct6373_1,
        &board_HW553,
        &board_spw303v,
index 2c7193c7dfcfbe539a90455673c4e775d691f9ca..7c0c133266bcfc20a83542ecc372d38917a1d308 100644 (file)
@@ -17,7 +17,7 @@
  
  #define CT6373_PID_OFFSET             0xff80
  #define CT6373_74X164_GPIO_BASE       64
-@@ -2387,6 +2390,105 @@ static struct board_info __initdata boar
+@@ -2388,6 +2391,105 @@ static struct board_info __initdata boar
  };
  #endif /* CONFIG_BCM63XX_CPU_6358 */
  
  /*
   * known 6368 boards
   */
-@@ -2590,6 +2692,10 @@ static const struct board_info __initcon
+@@ -2591,6 +2693,10 @@ static const struct board_info __initcon
        &board_DVAG3810BN,
  #endif
  
index 86d507f57bab924d78c51697d5dbfe4a96034d04..a5053939d3989e3209699ffdb6ae3c507b9300a2 100644 (file)
@@ -58,7 +58,7 @@
  static struct board_info __initdata board_rta1025w_16 = {
        .name                           = "RTA1025W_16",
        .of_board_id                    = "dynalink,rta1025w",
-@@ -2663,6 +2714,7 @@ static const struct board_info __initcon
+@@ -2664,6 +2715,7 @@ static const struct board_info __initcon
        &board_96348gw_10,
        &board_96348gw_11,
        &board_FAST2404,
index 272ee64e27163cc9fedba28c09f16d79831b2752..b85b961587643d06996c1f4f48dc04cd8f84a07b 100644 (file)
  static struct board_info __initdata board_dsl_274xb_f1 = {
        .name                           = "AW4339U",
        .expected_cpu_id                = 0x6328,
-@@ -2695,6 +2823,7 @@ static const struct board_info __initcon
+@@ -2696,6 +2824,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
        &board_963281TAN,
index 1ed660d866721c75b8182db7181fb9c3c23bda9c..3194899e82decd828af0dd3f57e8dcc1b765ef8b 100644 (file)
  static struct board_info __initdata board_963281TAN = {
        .name                           = "963281TAN",
        .expected_cpu_id                = 0x6328,
-@@ -2822,6 +2932,7 @@ static const struct board_info __initcon
+@@ -2823,6 +2933,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
index 93c83afe6ac00bc11f01b8cd1cfdbada9784ed18..e80009a27f1c1358c90397582cfd89038879f597 100644 (file)
@@ -93,7 +93,7 @@
  static struct sprom_fixup __initdata ar5387un_fixups[] = {
        { .offset = 2, .value = 0x05bb },
        { .offset = 65, .value = 0x1204 },
-@@ -2932,6 +3018,7 @@ static const struct board_info __initcon
+@@ -2933,6 +3019,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
index 4e46193be4fd0899fd60a6da94fb7251e0997cc4..e3fa82372fcd3c7e6722d63b920d90660c50cd18 100644 (file)
@@ -56,7 +56,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6345 */
  
  /*
-@@ -3032,6 +3081,7 @@ static const struct board_info __initcon
+@@ -3033,6 +3082,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6345
        &board_96345gw2,
index 1024dcead0edc67aacec7d7c098200eb3e17e9cc..f6b39c403305e9b11391ff49b191baca2892ed95 100644 (file)
@@ -8,7 +8,7 @@
  #include <linux/platform_device.h>
  #include <linux/spi/spi.h>
  #include <linux/spi/spi_gpio.h>
-@@ -2679,6 +2680,405 @@ static struct board_info __initdata boar
+@@ -2680,6 +2681,405 @@ static struct board_info __initdata boar
        },
  };
  
   /* T-Home Speedport W 303V Typ B */
  static struct board_info __initdata board_spw303v = {
        .name                   = "96358-502V",
-@@ -3117,6 +3517,9 @@ static const struct board_info __initcon
+@@ -3118,6 +3518,9 @@ static const struct board_info __initcon
        &board_nb4_fxc_r1,
        &board_ct6373_1,
        &board_HW553,
index 5fcb3bae3dc583023fb3849b89035cf29e544e56..509e41ea3f9e38c931f4855facc4c9474813ac39 100644 (file)
@@ -61,7 +61,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6345 */
  
  /*
-@@ -3482,6 +3536,7 @@ static const struct board_info __initcon
+@@ -3483,6 +3537,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6345
        &board_96345gw2,
        &board_rta770bw,
index fc8fe6280b88146be93d97123816a50c3049e3f3..cd0310003d05998d70afe53b8800eade5d7e448d 100644 (file)
@@ -135,7 +135,7 @@ Signed-off-by: Marcin Jurkowski <marcin1j@gmail.com>
  #endif /* CONFIG_BCM63XX_CPU_6328 */
  
  /*
-@@ -3526,6 +3642,7 @@ static const struct board_info __initcon
+@@ -3527,6 +3643,7 @@ static const struct board_info __initcon
        &board_963281TAN,
        &board_A4001N1,
        &board_dsl_274xb_f1,
index d4ad4e067e5112ba68d7667d9d9561217dd718bf..cedeac803ed3ed64a864080b344cc7c875d897fa 100644 (file)
@@ -6,7 +6,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
 ---
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -3481,6 +3481,96 @@ static struct board_info __initdata boar
+@@ -3482,6 +3482,96 @@ static struct board_info __initdata boar
        .devs = nb6_devices,
        .num_devs = ARRAY_SIZE(nb6_devices),
  };
@@ -103,7 +103,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
  #endif /* CONFIG_BCM63XX_CPU_6362 */
  
  /*
-@@ -3698,6 +3788,7 @@ static const struct board_info __initcon
+@@ -3699,6 +3789,7 @@ static const struct board_info __initcon
  
  #ifdef CONFIG_BCM63XX_CPU_6362
        &board_nb6,
index ef33a416997d1be8298651992a6c04e0ef20c1fe..7b9fa914c0e3236823e1aa534d136b7e3790cb4c 100644 (file)
@@ -94,7 +94,7 @@
   * known 6328 boards
   */
  #ifdef CONFIG_BCM63XX_CPU_6328
-@@ -3956,6 +4043,9 @@ static const struct board_info __initcon
+@@ -3957,6 +4044,9 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_3368
        &board_cvg834g,
  #endif
index 9723d2ae727abdc4bb3ac88c47b66afa41fd3988..38fe7559fc7537ef45347d5df3d6927a3a6955d0 100644 (file)
@@ -95,7 +95,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -4045,6 +4133,7 @@ static const struct board_info __initcon
+@@ -4046,6 +4134,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
index 1e26edf9dc2b21fd6e65c0338cbf04fed4f639b0..7a3cea57271efba2df84587c9ab2aed80db9f1ed 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4125,6 +4125,75 @@ static struct board_info __initdata boar
+@@ -4126,6 +4126,75 @@ static struct board_info __initdata boar
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
@@ -76,7 +76,7 @@
   * all boards
   */
  static const struct board_info __initconst *bcm963xx_boards[] = {
-@@ -4205,6 +4274,9 @@ static const struct board_info __initcon
+@@ -4206,6 +4275,9 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
  #endif
index 2d520473d3d39d235ad388088ef8fe9eaa7e2cc6..1d485b6becce6a14e58ff7f8b294b8eb9cc08837 100644 (file)
@@ -61,7 +61,7 @@ Signed-off-by: Adrian Feliks <mexit@o2.pl>
  
  /* BT Voyager 2110 */
  static struct board_info __initdata board_V2110 = {
-@@ -4245,6 +4291,7 @@ static const struct board_info __initcon
+@@ -4246,6 +4292,7 @@ static const struct board_info __initcon
        &board_96348A_122,
        &board_CPVA502plus,
        &board_96348W3,
index 8f46d1b55b2e389520864b16c214f4f7a43ca60f..f92ce6f023b076964864a2941802d488281bbb42 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4237,6 +4237,108 @@ static struct board_info __initdata boar
+@@ -4238,6 +4238,108 @@ static struct board_info __initdata boar
                },
        },
  };
  #endif /* CONFIG_BCM63XX_CPU_63268 */
  
  /*
-@@ -4323,6 +4425,7 @@ static const struct board_info __initcon
+@@ -4324,6 +4426,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963269bhr,
index b0208171ae441ba297ab4826dc76f2497f6bf375..d9a704f97ac129eb79b2b14ec218a94e0a7b7e91 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4174,6 +4174,131 @@ static struct board_info __initdata boar
+@@ -4175,6 +4175,131 @@ static struct board_info __initdata boar
   * known 63268/63269 boards
   */
  #ifdef CONFIG_BCM63XX_CPU_63268
  static struct board_info __initdata board_963269bhr = {
        .name                           = "963269BHR",
        .expected_cpu_id                = 0x63268,
-@@ -4424,6 +4549,7 @@ static const struct board_info __initcon
+@@ -4425,6 +4550,7 @@ static const struct board_info __initcon
        &board_96368mvngr,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
index 428e796d04b9fd7c489c45d3d50d24dd4bf4f8b6..f48eaeb20eb9083116b0c0a0fd1bb6a1fefeeb0a 100644 (file)
@@ -8,7 +8,7 @@
  #include <linux/platform_device.h>
  #include <linux/spi/spi.h>
  #include <linux/spi/spi_gpio.h>
-@@ -4168,6 +4169,118 @@ static struct board_info __initdata boar
+@@ -4169,6 +4170,118 @@ static struct board_info __initdata boar
        .has_ohci0 = 1,
        .has_ehci0 = 1,
  };
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
-@@ -4547,6 +4660,7 @@ static const struct board_info __initcon
+@@ -4548,6 +4661,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index 29e3a797ea545bb7155f493917037e778bbc6689..61afff60c80c922d5dcb146716b69298d8c79694 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4170,6 +4170,117 @@ static struct board_info __initdata boar
+@@ -4171,6 +4171,117 @@ static struct board_info __initdata boar
        .has_ehci0 = 1,
  };
  
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -4660,6 +4771,7 @@ static const struct board_info __initcon
+@@ -4661,6 +4772,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index 9a6ac99667981dc12bcd7bc04037d1afef5077e0..7ef72ec5358bbc380a94c9427a83a66b80c11deb 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4281,6 +4281,117 @@ static struct board_info __initdata boar
+@@ -4282,6 +4282,117 @@ static struct board_info __initdata boar
        },
  };
  
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -4772,6 +4883,7 @@ static const struct board_info __initcon
+@@ -4773,6 +4884,7 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
        &board_VR3025u,
index 1ed7580502c5b8206fa31fd6796e83078d73355c..368f28a1af364757febaababd53ffe9db324bed7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4179,6 +4179,96 @@ static struct sprom_fixup __initdata vr3
+@@ -4180,6 +4180,96 @@ static struct sprom_fixup __initdata vr3
        { .offset = 115, .value = 0xfad9 },
  };
  
@@ -97,7 +97,7 @@
  static struct board_info __initdata board_VR3025u = {
        .name                                   = "96368M-1541N",
        .of_board_id                    = "comtrend,vr-3025u",
-@@ -4882,6 +4972,7 @@ static const struct board_info __initcon
+@@ -4883,6 +4973,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index eb59a404aade93af874429ef07e81cc708da19d1..7ac322003fe488486e5ac3b572ba9d0f5e526079 100644 (file)
@@ -57,8 +57,8 @@
 +
  static struct board_info __initdata board_HW553 = {
        .name                           = "HW553",
-       .expected_cpu_id                = 0x6358,
-@@ -4956,6 +5007,7 @@ static const struct board_info __initcon
+       .of_board_id                                    = "huawei,hg553",
+@@ -4957,6 +5008,7 @@ static const struct board_info __initcon
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
        &board_ct6373_1,
index 7846aeff82838f1710bb2c5071800a5d2dd86282..09b80b31127e5037d929f9107d43bb5cf3f3b407 100644 (file)
@@ -97,7 +97,7 @@
  static struct board_info __initdata board_A4001N1 = {
        .name                                   = "963281T_TEF",
        .of_board_id                    = "adb,a4001n1",
-@@ -4958,6 +5048,7 @@ static const struct board_info __initcon
+@@ -4959,6 +5049,7 @@ static const struct board_info __initcon
        &board_AR5381u,
        &board_AR5387un,
        &board_963281TAN,
index 706142ddd796694aa34f967a0e5ba991d2374f35..7188ba3f9a35868e77ea3d501e9a46f727803ae3 100644 (file)
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -5042,6 +5177,7 @@ static const struct board_info __initcon
+@@ -5043,6 +5178,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
        &board_96318ref_p300,
index 1014884143e8459098c8788154aa66b2e08bf720..594389ec0e151be5baeb8c016fbfff0ccc7e2e72 100644 (file)
@@ -14,6 +14,16 @@ define Profile/HG520v/Description
 endef
 $(eval $(call Profile,HG520v))
 
+define Profile/HG553
+  NAME:=Huawei EchoLife HG553
+  PACKAGES:=kmod-b43 wpad-mini \
+       kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev
+endef
+define Profile/HG553/Description
+  Package set optimized for Huawei HG553.
+endef
+$(eval $(call Profile,HG553))
+
 define Profile/HG556a_AB
   NAME:=Huawei EchoLife HG556a (version A/B - Atheros)
   PACKAGES:=kmod-ath9k wpad-mini \