brcm63xx: Add DT support for AGPF-S0
authorJonas Gorski <jogo@openwrt.org>
Mon, 24 Nov 2014 14:44:12 +0000 (14:44 +0000)
committerJonas Gorski <jogo@openwrt.org>
Mon, 24 Nov 2014 14:44:12 +0000 (14:44 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
SVN-Revision: 43358

target/linux/brcm63xx/dts/agpf-s0.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/profiles/pirelli.mk [new file with mode: 0644]

diff --git a/target/linux/brcm63xx/dts/agpf-s0.dts b/target/linux/brcm63xx/dts/agpf-s0.dts
new file mode 100644 (file)
index 0000000..9d66b89
--- /dev/null
@@ -0,0 +1,30 @@
+/dts-v1/;
+
+/include/ "bcm6358.dtsi"
+
+/ {
+       model = "Pirelli Alice Gate AGPF-S0";
+       compatible = "pirelli,agpf-s0", "brcm,bcm6358";
+};
+
+&pflash {
+       status = "ok";
+
+       linux,part-probe = "bcm63xxpart";
+
+       cfe@0 {
+               label = "CFE";
+               reg = <0x000000 0x020000>;
+               read-only;
+       };
+
+       linux@20000 {
+               label = "linux";
+               reg = <0x020000 0xfc0000>;
+       };
+
+       nvram@fe0000 {
+               label = "nvram";
+               reg = <0xfe0000 0x020000>;
+       };
+};
index b7789cf368bd7b80af097da0523429ae62e2fbb6..2b57fcd98577493f8dbabcb31e192d86e741fe90 100755 (executable)
@@ -288,9 +288,6 @@ define Image/Build
        $(call Image/Build/CFE,$(1),F@ST2704V2,6328,F@ST2704V2,OpenWRT-$(REVISION))
        # Inventel Livebox
        $(call Image/Build/RedBoot,livebox)
-       # Pirelli Alice Gate VoIP 2 Plus Wi-Fi AGPF-S0
-       $(call Image/Build/CFEAGPF,$(1),AGPF-S0,6358,0x20000,AGV2+W-cfe)
-       $(call Image/Build/CFEAGPF,$(1),AGPF-S0,6358,0x20000,AGV2+W)
        # Pirelli A226G
        $(call Image/Build/CFEAGPF,$(1),DWV-S0,6358,0x10000,A226G-cfe)
        $(call Image/Build/CFEAGPF,$(1),DWV-S0,6358,0x10000,A226G)
@@ -388,6 +385,8 @@ $(eval $(call CfeImageDTB,HG553,hg553,HW553,6358,HG553,EchoLife_HG553,--image-of
 $(eval $(call CfeImageDTB,HG556a_AB,hg556a-a,HW556,6358,HG556a_A,EchoLife_HG556a,--image-offset 0x20000 --block-size 0x10000 --tag-version 8))
 $(eval $(call CfeImageDTB,HG556a_AB,hg556a-b,HW556,6358,HG556a_B,EchoLife_HG556a,--image-offset 0x20000 --block-size 0x20000 --tag-version 8))
 $(eval $(call CfeImageDTB,HG556a_C,hg556a-c,HW556,6358,HG556a_C,EchoLife_HG556a,--image-offset 0x20000 --block-size 0x20000 --tag-version 8))
+# Pirelli Alice Gate VoIP 2 Plus Wi-Fi AGPF-S0
+$(eval $(call CfeImageDTB,AGPF_S0,agpf-s0,AGPF-S0,6358,AGV2+W,,--block-size 0x20000 --image-offset 0x20000 --signature2 IMAGE --tag-version 8))
 # T-Com Speedport W 500V
 $(eval $(call CfeImageDTB,SPW500V,spw500v,96348GW,6348,SPW500V))
 # Tecom GW6000
diff --git a/target/linux/brcm63xx/profiles/pirelli.mk b/target/linux/brcm63xx/profiles/pirelli.mk
new file mode 100644 (file)
index 0000000..c06852e
--- /dev/null
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/AGPF_S0
+  NAME:=Pirelli Alice Gate VoIP 2 Plus Wi-Fi AGPF-S0
+  PACKAGES:=kmod-b43 wpad-mini\
+       kmod-usb2 kmod-usb-ohci
+endef
+define Profile/AGPF_S0/Description
+  Package set optimized for AGPF-S0.
+endef
+$(eval $(call Profile,AGPF_S0))