package/grub: revert accidental/unessesery grub commit
authorAlexandros C. Couloumbis <alex@ozo.com>
Fri, 1 Oct 2010 16:43:46 +0000 (16:43 +0000)
committerAlexandros C. Couloumbis <alex@ozo.com>
Fri, 1 Oct 2010 16:43:46 +0000 (16:43 +0000)
SVN-Revision: 23170

package/grub/Makefile

index 502035a1c52a017802de9f3037edae1a9034da53..ee527be13f4adc22360e8ed8a0088600932a59ce 100644 (file)
@@ -49,8 +49,8 @@ ifeq ($(HOST_OS),Darwin)
   HOST_CFLAGS += $(call host-cc-option,-fnested-functions)
 endif
 
-ifeq ($(HOST_ARCH),amd64)
-  ifeq ($(HOST_OS),FreeBSD)
+ifeq ($(HOST_OS),FreeBSD)
+  ifeq ($(HOST_ARCH),amd64)
     HOST_CFLAGS += $(call host-cc-option,-m32)
     HOST_CFLAGS += $(call host-cc-option,-B/usr/lib32)
     HOST_CFLAGS += $(call host-cc-option,-L/usr/lib32)