tty detect fix
authorFelix Fietkau <nbd@openwrt.org>
Sun, 12 Nov 2006 02:56:35 +0000 (02:56 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 12 Nov 2006 02:56:35 +0000 (02:56 +0000)
SVN-Revision: 5510

Makefile

index 62a03387463aed51e47d3c46ccb9d19928d799df..e5e1f6fd3110cd1c7eddde05af84b6da2b9be223 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -24,10 +24,7 @@ export TOPDIR=${shell pwd}
 ifeq ($(KBUILD_VERBOSE),99)
   MAKE:=3>/dev/null $(MAKE)
 endif
-ifneq ($(shell tty -s <&3 || echo x),x)
-  IS_TTY=1
-  export IS_TTY
-endif
+export IS_TTY=$(shell tty -s && echo 1 || echo 0)
 
 include $(TOPDIR)/include/verbose.mk