imagebuilder: use correct package directory when bundling kmods and libc
authorJo-Philipp Wich <jo@mein.io>
Fri, 22 Apr 2016 10:22:57 +0000 (12:22 +0200)
committerJo-Philipp Wich <jo@mein.io>
Fri, 22 Apr 2016 10:22:57 +0000 (12:22 +0200)
The libc and kernel package files moved since the introduction of shared
packages and the changed output directory layout. This causes the generated
ImageBuilder archive to lack the necessary "libc" and "kernel" meta packages,
leading to opkg install errors later on.

Use the FeedPackageDir macro to figure out the proper source directory to use.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
target/imagebuilder/Makefile

index 87f91ce07776e402a64d837a013025388aca3993..b49153b889b63f085d25e22f8cb62b4095c553bb 100644 (file)
@@ -47,10 +47,10 @@ endif
        $(VERSION_SED) $(PKG_BUILD_DIR)/repositories.conf
 
 ifeq ($(CONFIG_IB_STANDALONE),)
-       (cd $(PACKAGE_DIR); $(FIND) -type f -name 'libc_*.ipk' -or -name 'kernel_*.ipk' -or -name 'kmod-*.ipk') | \
+       (cd $(call FeedPackageDir,libc); $(FIND) -type f -name 'libc_*.ipk' -or -name 'kernel_*.ipk' -or -name 'kmod-*.ipk') | \
                while read path; do \
                        mkdir -p "$(PKG_BUILD_DIR)/packages/$${path%/*}"; \
-                       cp "$(PACKAGE_DIR)/$$path" "$(PKG_BUILD_DIR)/packages/$$path"; \
+                       cp "$(call FeedPackageDir,libc)/$$path" "$(PKG_BUILD_DIR)/packages/$$path"; \
                done
 else
        $(INSTALL_DIR) $(PKG_BUILD_DIR)/packages