brcm2708: switch device tree compilation to linux
authorJohn Crispin <john@openwrt.org>
Mon, 5 Oct 2015 10:27:34 +0000 (10:27 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 5 Oct 2015 10:27:34 +0000 (10:27 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
SVN-Revision: 47124

target/linux/brcm2708/Makefile
target/linux/brcm2708/image/Makefile

index 6d8aba018aa6b656bfc6eaeced509bc2fe40730d..f8c93474c5ca7cd45bea0dba8cee5fcd01561d4a 100644 (file)
@@ -26,6 +26,6 @@ define Target/Description
        Currently produces SD Card image for Raspberry Pi.
 endef
 
-KERNELNAME:=Image
+KERNELNAME:=Image dtbs
 
 $(eval $(call BuildTarget))
index de222f08019e2f6d3e17a1032b3bc22db0251e28..7a68c506cfb3a1734af73243c6e39a09e35c7f66 100644 (file)
@@ -22,10 +22,6 @@ else
 endif
 
 ### Image scripts ###
-define Build/build-dtb
-       $(call Image/BuildDTB,$(DTS_DIR)/$(DEVICE_DTS).dts,$@.dtb)
-endef
-
 define Build/gen-cfg
        cat config.txt > $@.config
        echo -e "\ndevice_tree=$(DEVICE_DTS).dtb" >> $@.config
@@ -44,7 +40,7 @@ define Build/boot-img
        mcopy -i $@.boot cmdline.txt ::
        mcopy -i $@.boot $@.config ::config.txt
        mcopy -i $@.boot $(word 1,$^) ::kernel.img
-       mcopy -i $@.boot $@.dtb ::$(DEVICE_DTS).dtb
+       mcopy -i $@.boot $(DTS_DIR)/$(DEVICE_DTS).dtb ::$(DEVICE_DTS).dtb
 endef
 
 define Build/sdcard-img
@@ -59,7 +55,7 @@ define Device/Default
   PROFILES = Default $$(DEVICE_PROFILE)
   KERNEL := kernel-bin
   IMAGES := sdcard.bin
-  IMAGE/sdcard.bin := build-dtb | gen-cfg | boot-img | sdcard-img
+  IMAGE/sdcard.bin := gen-cfg | boot-img | sdcard-img
   DEVICE_PROFILE :=
   DEVICE_DTS :=
 endef