kernel: bump 4.9 to 4.9.122
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 20 Aug 2018 08:32:54 +0000 (10:32 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 20 Aug 2018 11:03:22 +0000 (13:03 +0200)
Refreshed all patches.

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/hack-4.9/207-disable-modorder.patch
target/linux/generic/hack-4.9/220-gc_sections.patch
target/linux/generic/pending-4.9/201-extra_optimization.patch

index a74892113d5e413d3fbfea48f5f3498f219ec6f4..857ae72ffc062d56230bbbaaa7a2a2d5828a5d67 100644 (file)
@@ -3,12 +3,12 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .71
-LINUX_VERSION-4.9 = .120
 LINUX_VERSION-4.14 = .63
+LINUX_VERSION-4.9 = .122
 
 LINUX_KERNEL_HASH-3.18.71 = 5abc9778ad44ce02ed6c8ab52ece8a21c6d20d21f6ed8a19287b4a38a50c1240
-LINUX_KERNEL_HASH-4.9.120 = d75af506865edc8145a344c4e73c3bb1000e6c9f1c3489b8dae47ca8f033fd91
 LINUX_KERNEL_HASH-4.14.63 = cd2e52f0e7ba861afa91cf487b2f45e5174115870f256a1d65996647b7bcc6d3
+LINUX_KERNEL_HASH-4.9.122 = a46f90876b2cdb8ca1626e6489e76f8706dfd593a9d44fc91e68df47db6cf86c
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 1a72c91be22ec0f03c2c88054a15391fb3975a5e..22e863c2866cfdf6b32654cb0205e7916fab0e18 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -1212,7 +1212,6 @@ all: modules
+@@ -1213,7 +1213,6 @@ all: modules
  
  PHONY += modules
  modules: $(vmlinux-dirs) $(if $(KBUILD_BUILTIN),vmlinux) modules.builtin
@@ -23,7 +23,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        @$(kecho) '  Building modules, stage 2.';
        $(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost
        $(Q)$(MAKE) -f $(srctree)/scripts/Makefile.fwinst obj=firmware __fw_modbuild
-@@ -1242,7 +1241,6 @@ _modinst_:
+@@ -1243,7 +1242,6 @@ _modinst_:
                rm -f $(MODLIB)/build ; \
                ln -s $(CURDIR) $(MODLIB)/build ; \
        fi
index a041ff1d03143e5d899a7651557945518ef5e173..31317448992b89efa825d1f0aa8b2658397b849f 100644 (file)
@@ -33,7 +33,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  # Read KERNELRELEASE from include/config/kernel.release (if it exists)
  KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
  KERNELVERSION = $(VERSION)$(if $(PATCHLEVEL),.$(PATCHLEVEL)$(if $(SUBLEVEL),.$(SUBLEVEL)))$(EXTRAVERSION)
-@@ -637,11 +642,6 @@ KBUILD_CFLAGS     += $(call cc-disable-warni
+@@ -638,11 +643,6 @@ KBUILD_CFLAGS     += $(call cc-disable-warni
  KBUILD_CFLAGS += $(call cc-disable-warning, int-in-bool-context)
  KBUILD_CFLAGS += $(call cc-disable-warning, attribute-alias)
  
index 3e878e96d65330828cb11ce4ca148cd3c38c428c..8197f7bb9f103ba151e4f97cea80ed96d5a44e61 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -643,12 +643,12 @@ KBUILD_CFLAGS    += $(call cc-option,-fdata
+@@ -644,12 +644,12 @@ KBUILD_CFLAGS    += $(call cc-option,-fdata
  endif
  
  ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE