gre: Change hostdependcy to remote endpoint tunnel address
authorSteven Barth <cyrus@openwrt.org>
Tue, 5 Aug 2014 09:57:55 +0000 (09:57 +0000)
committerSteven Barth <cyrus@openwrt.org>
Tue, 5 Aug 2014 09:57:55 +0000 (09:57 +0000)
Depend on the GRE tunnel peeraddr to trigger setup of the tunnel interface.
Addresses the issue reported in https://lists.openwrt.org/pipermail/openwrt-devel/2014-August/027201.html

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
SVN-Revision: 41998

package/network/config/gre/Makefile
package/network/config/gre/files/gre.sh

index efca4643d5dd2d931b8ff68a935d1219b08b4fd8..9f5135e5a5472464039719709f27536b17051303 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gre
 PKG_VERSION:=1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 include $(INCLUDE_DIR)/package.mk
 
index 38c0fc4841044ed0e66dadf8961b37e06ae9afed..1728b01fcca702d5e3b64a1af39c44f34fd55fe7 100755 (executable)
@@ -51,7 +51,7 @@ gre_setup() {
                exit
        }
 
-       ( proto_add_host_dependency "$cfg" "0.0.0.0" "$tunlink" )
+       ( proto_add_host_dependency "$cfg" "$peeraddr" "$tunlink" )
 
        [ -z "$ipaddr" ] && {
                local wanif="$tunlink"
@@ -108,7 +108,7 @@ grev6_setup() {
                exit
        }
 
-       ( proto_add_host_dependency "$cfg" "::" "$tunlink" )
+       ( proto_add_host_dependency "$cfg" "$peer6addr" "$tunlink" )
 
        [ -z "$ip6addr" ] && {
                local wanif="$tunlink"