move busybox init scripts from base-files into the busybox package and make them...
authorFelix Fietkau <nbd@openwrt.org>
Wed, 22 Nov 2006 23:06:40 +0000 (23:06 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 22 Nov 2006 23:06:40 +0000 (23:06 +0000)
SVN-Revision: 5620

package/base-files/default/etc/init.d/cron [deleted file]
package/base-files/default/etc/init.d/httpd [deleted file]
package/base-files/default/etc/init.d/telnet [deleted file]
package/busybox/Makefile
package/busybox/files/cron [new file with mode: 0755]
package/busybox/files/httpd [new file with mode: 0755]
package/busybox/files/telnet [new file with mode: 0755]

diff --git a/package/base-files/default/etc/init.d/cron b/package/base-files/default/etc/init.d/cron
deleted file mode 100755 (executable)
index e78d023..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
-
-start () {
-       mkdir -p /var/spool/cron
-       [ -L /var/spool/cron/crontabs ] || ln -s /etc/crontabs /var/spool/cron/crontabs
-       crond -c /etc/crontabs
-}
-
-stop() {
-       killall crond
-}
diff --git a/package/base-files/default/etc/init.d/httpd b/package/base-files/default/etc/init.d/httpd
deleted file mode 100755 (executable)
index e4f5f48..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
-
-start() {
-       include /lib/network
-       scan_interfaces
-        config_get ifname wan hostname
-       [ -d /www ] && httpd -p 80 -h /www -r ${hostname:-OpenWrt}
-}
-
-stop() {
-       killall httpd
-}
diff --git a/package/base-files/default/etc/init.d/telnet b/package/base-files/default/etc/init.d/telnet
deleted file mode 100755 (executable)
index c994c60..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
-
-start() {
-       if awk -F: '/^root:/ && $2 !~ /\!/ {exit 1}' /etc/passwd 2>/dev/null && [ -x /usr/sbin/dropbear ]; then telnetd -l /bin/login; fi
-}
-
-stop() {
-       killall telnetd
-}
index cc347372643c09f00139c08e2f9e3cd4c1fe35dd..0c1efc470aa912d44f07f11a7e265cd4e0b0c643 100644 (file)
@@ -21,6 +21,11 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
+init-y :=
+init-$(CONFIG_BUSYBOX_CONFIG_HTTPD) += httpd
+init-$(CONFIG_BUSYBOX_CONFIG_CROND) += cron
+init-$(CONFIG_BUSYBOX_CONFIG_TELNETD) += telnet
+
 define Package/busybox
   SECTION:=base
   CATEGORY:=Base system
@@ -66,6 +71,10 @@ define Package/busybox/install
                IPKG_ARCH="$(ARCH)" \
                PREFIX="$(1)" \
                install
+       mkdir -p $(1)/etc/init.d
+       for tmp in $(init-y); do \
+               $(INSTALL_BIN) ./files/$$$$tmp $(1)/etc/init.d/$$$$tmp; \
+       done
        -rm -rf $(1)/lib64
 endef
 
diff --git a/package/busybox/files/cron b/package/busybox/files/cron
new file mode 100755 (executable)
index 0000000..e78d023
--- /dev/null
@@ -0,0 +1,12 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2006 OpenWrt.org
+
+start () {
+       mkdir -p /var/spool/cron
+       [ -L /var/spool/cron/crontabs ] || ln -s /etc/crontabs /var/spool/cron/crontabs
+       crond -c /etc/crontabs
+}
+
+stop() {
+       killall crond
+}
diff --git a/package/busybox/files/httpd b/package/busybox/files/httpd
new file mode 100755 (executable)
index 0000000..e4f5f48
--- /dev/null
@@ -0,0 +1,13 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2006 OpenWrt.org
+
+start() {
+       include /lib/network
+       scan_interfaces
+        config_get ifname wan hostname
+       [ -d /www ] && httpd -p 80 -h /www -r ${hostname:-OpenWrt}
+}
+
+stop() {
+       killall httpd
+}
diff --git a/package/busybox/files/telnet b/package/busybox/files/telnet
new file mode 100755 (executable)
index 0000000..c994c60
--- /dev/null
@@ -0,0 +1,10 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2006 OpenWrt.org
+
+start() {
+       if awk -F: '/^root:/ && $2 !~ /\!/ {exit 1}' /etc/passwd 2>/dev/null && [ -x /usr/sbin/dropbear ]; then telnetd -l /bin/login; fi
+}
+
+stop() {
+       killall telnetd
+}