kernel: bump 5.10 to 5.10.81
authorJohn Audia <graysky@archlinux.us>
Sun, 21 Nov 2021 13:39:18 +0000 (08:39 -0500)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 27 Nov 2021 18:19:11 +0000 (19:19 +0100)
Manually rebased:
    octeontx/patches-5.10/0004-PCI-add-quirk-for-Gateworks-PLX-PEX860x-switch-with-.patch

All other patches automatically rebased.

Build system: x86_64
Build-tested: bcm2711/RPi4B, ipq806x/R7800
Run-tested: bcm2711/RPi4B, ipq806x/R7800

Signed-off-by: John Audia <graysky@archlinux.us>
include/kernel-version.mk
target/linux/generic/backport-5.10/732-net-next-1-of-net-pass-the-dst-buffer-to-of_get_mac_address.patch
target/linux/generic/backport-5.10/821-v5.13-let-pci-host-bridges-declar-their-reliance-on-msi-domains.patch
target/linux/generic/pending-5.10/920-mangle_bootargs.patch
target/linux/ipq806x/patches-5.10/0067-generic-Mangle-bootloader-s-kernel-arguments.patch
target/linux/lantiq/patches-5.10/0001-MIPS-lantiq-add-pcie-driver.patch
target/linux/mvebu/patches-5.10/300-mvebu-Mangle-bootloader-s-kernel-arguments.patch
target/linux/octeontx/patches-5.10/0004-PCI-add-quirk-for-Gateworks-PLX-PEX860x-switch-with-.patch
target/linux/oxnas/patches-5.10/996-generic-Mangle-bootloader-s-kernel-arguments.patch

index 44bfcaf052c114d839a907564797530f4356e733..a6a3d18b442b4b0b3e3e5fcd57ac3d657ed97c5e 100644 (file)
@@ -7,10 +7,10 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-5.4 = .159
-LINUX_VERSION-5.10 = .80
+LINUX_VERSION-5.10 = .81
 
 LINUX_KERNEL_HASH-5.4.159 = d718325f4eab325dce4f82b88418f68ba130864118229539541331e0a4478643
-LINUX_KERNEL_HASH-5.10.80 = 477ce8f7624263e4346c0fc25ffc334af06bcac4d6bebdd5a7fe4681557fdb39
+LINUX_KERNEL_HASH-5.10.81 = a2e1686132c4598c0adfdf52acbf1ab4bb327b2398badef346a0eff849da5adb
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index ab723b7b42519e3d49c02fc47b28284b363f6c38..faf7b9c5d0784102e703aefc66dfcfdd3a6696cc 100644 (file)
@@ -1283,7 +1283,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                return PTR_ERR(plat_dat);
 --- a/drivers/net/ethernet/stmicro/stmmac/dwmac-rk.c
 +++ b/drivers/net/ethernet/stmicro/stmmac/dwmac-rk.c
-@@ -1396,7 +1396,7 @@ static int rk_gmac_probe(struct platform
+@@ -1387,7 +1387,7 @@ static int rk_gmac_probe(struct platform
        if (ret)
                return ret;
  
@@ -1360,7 +1360,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        int irq;
 --- a/drivers/net/ethernet/stmicro/stmmac/stmmac_main.c
 +++ b/drivers/net/ethernet/stmicro/stmmac/stmmac_main.c
-@@ -4904,7 +4904,7 @@ int stmmac_dvr_probe(struct device *devi
+@@ -4957,7 +4957,7 @@ int stmmac_dvr_probe(struct device *devi
        priv->wol_irq = res->wol_irq;
        priv->lpi_irq = res->lpi_irq;
  
index 9cf63af3332d590d84a8ac1122b388d91978b5da..854dc34c42c0ff65f54ca8fe33f0a21797455181 100644 (file)
@@ -34,7 +34,7 @@ Acked-by: Bjorn Helgaas <bhelgaas@google.com>
                set_dev_node(bus->bridge, pcibus_to_node(bus));
 --- a/include/linux/pci.h
 +++ b/include/linux/pci.h
-@@ -545,6 +545,7 @@ struct pci_host_bridge {
+@@ -547,6 +547,7 @@ struct pci_host_bridge {
        unsigned int    native_dpc:1;           /* OS may use PCIe DPC */
        unsigned int    preserve_config:1;      /* Preserve FW resource setup */
        unsigned int    size_windows:1;         /* Enable root bus sizing */
index e5b7fd81d1dc809ed0f7433e435275c7c1835954..d8f5c06b7ee8a447aa2c7992b71a23408f05bb78 100644 (file)
@@ -31,7 +31,7 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
        help
 --- a/init/main.c
 +++ b/init/main.c
-@@ -607,6 +607,29 @@ static inline void setup_nr_cpu_ids(void
+@@ -608,6 +608,29 @@ static inline void setup_nr_cpu_ids(void
  static inline void smp_prepare_cpus(unsigned int maxcpus) { }
  #endif
  
@@ -61,7 +61,7 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
  /*
   * We need to store the untouched command line for future reference.
   * We also need to store the touched command line since the parameter
-@@ -868,6 +891,7 @@ asmlinkage __visible void __init __no_sa
+@@ -869,6 +892,7 @@ asmlinkage __visible void __init __no_sa
        pr_notice("%s", linux_banner);
        early_security_init();
        setup_arch(&command_line);
index 25c58bee4968b31b42456e41abe48dfdbaee034e..8f669319edbeb5dc50a40b5f520a2a5f3792037c 100644 (file)
@@ -189,7 +189,7 @@ Signed-off-by: Adrian Panella <ianchi74@outlook.com>
  static int kernel_init(void *);
  
  extern void init_IRQ(void);
-@@ -905,6 +909,18 @@ asmlinkage __visible void __init __no_sa
+@@ -906,6 +910,18 @@ asmlinkage __visible void __init __no_sa
        pr_notice("Kernel command line: %s\n", saved_command_line);
        /* parameters may set static keys */
        jump_label_init();
index c3299317917ea61e84e612797479786721141755..786091a57e049fa404193ec479765937ca5f8676 100644 (file)
@@ -5481,7 +5481,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
          (transaction layer end-to-end CRC checking).
 --- a/include/linux/pci.h
 +++ b/include/linux/pci.h
-@@ -1417,6 +1417,8 @@ void pci_walk_bus(struct pci_bus *top, i
+@@ -1419,6 +1419,8 @@ void pci_walk_bus(struct pci_bus *top, i
                  void *userdata);
  int pci_cfg_space_size(struct pci_dev *dev);
  unsigned char pci_bus_max_busnr(struct pci_bus *bus);
index 15128828e99386dfa92b89e778172468a23f53fd..36f10fcfb52c5b64ccfbb73bf94a7bc0b1184013 100644 (file)
@@ -187,7 +187,7 @@ Signed-off-by: Michael Gray <michael.gray@lantisproject.com>
  static int kernel_init(void *);
  
  extern void init_IRQ(void);
-@@ -903,6 +907,18 @@ asmlinkage __visible void __init __no_sa
+@@ -904,6 +908,18 @@ asmlinkage __visible void __init __no_sa
        page_alloc_init();
  
        pr_notice("Kernel command line: %s\n", saved_command_line);
index 9bedaa1a87d5578f1ee8fec12d13d255bf33d21d..c7e39e07b7163ffaffec3abc280a0f50f1dabfa2 100644 (file)
@@ -22,10 +22,10 @@ Signed-off-by: Tim Harvey <tharvey@gateworks.com>
  #include <linux/platform_data/x86/apple.h>
  #include <linux/pm_runtime.h>
  #include <linux/suspend.h>
-@@ -5763,3 +5764,34 @@ static void apex_pci_fixup_class(struct
+@@ -5769,3 +5770,34 @@ static void nvidia_ion_ahci_fixup(struct
+       pdev->dev_flags |= PCI_DEV_FLAGS_HAS_MSI_MASKING;
  }
- DECLARE_PCI_FIXUP_CLASS_HEADER(0x1ac1, 0x089a,
-                              PCI_CLASS_NOT_DEFINED, 8, apex_pci_fixup_class);
+ DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_NVIDIA, 0x0ab8, nvidia_ion_ahci_fixup);
 +
 +#ifdef CONFIG_PCI_HOST_THUNDER_PEM
 +/*
index 4b89260660c8a4ef7b97b6759d1e424dab677649..898e60230656becb7dd68f0e796c446f2ebf5bd1 100644 (file)
@@ -168,7 +168,7 @@ Signed-off-by: Adrian Panella <ianchi74@outlook.com>
  static int kernel_init(void *);
  
  extern void init_IRQ(void);
-@@ -903,6 +907,18 @@ asmlinkage __visible void __init __no_sa
+@@ -904,6 +908,18 @@ asmlinkage __visible void __init __no_sa
        page_alloc_init();
  
        pr_notice("Kernel command line: %s\n", saved_command_line);